VMware Aria Orchestrator 8.16.1 displays "There is no valid license in the system. Check server license for details." error
search cancel

VMware Aria Orchestrator 8.16.1 displays "There is no valid license in the system. Check server license for details." error

book

Article ID: 345986

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • VMware Aria Orchestrator 8.16.1 displays "There is no valid license in the system. Check server license for details." error:

image.png

 

  • From vco-server-app.log, we can find error messages "Server license check: FAILED".

WARN vco [host='vco-app-7b45dc5894-57vcl' thread='pool-7-thread-3' user='' org='' trace=''] {} com.vmware.o11n.service.healthstatus.LicenseHealth - Server license check: FAILED

 WARN vco [host='vco-app-7b45dc5894-57vcl' thread='pool-7-thread-3' user='' org='' trace=''] {} com.vmware.o11n.service.healthstatus.LicenseHealth - Server license check: FAILED

vco [host='vco-app-7b45dc5894-57vcl' thread='pool-7-thread-2' user='' org='' trace=''] {} com.vmware.o11n.service.healthstatus.LicenseHealth - Server license check: FAILED


Environment

VMware vRealize Orchestrator 8.x

Cause

  • License check on VRO seems to not consider the non VCF/VVF license editions.

Resolution

  • This a known issue and is fixed in VMware Aria Orchestrator 8.16.2