Tenant App plugin does not work after a period of time
search cancel

Tenant App plugin does not work after a period of time

book

Article ID: 345973

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

The purpose of the article is to aware users of this known issue and resolve the accessibility of the plugin.

Symptoms:
  • The users have the option to access the Tenant App directly through vCloud Director with the help of plug-in.
image.png
  • It has been observed that after some time, the Tenant App plugin does not work and the users are prompted to enter the credentials.
image.png
 


Environment

VMware vRealize Operations 8.x

Cause

1. There is a password policy defined in vRealize Operations due to which the users are required to change their passwords.
2. The default value is 90 days, users can modify it according to their requirements.
3. It is found in Administration -> Global Settings -> User Access -> Password Change
image.png
4. When the defined time period is over and users need to change the password, Tenant App plugin also stop working.

Resolution

Currently there is no resolution.

Workaround:

Follow the below steps:

  1. Log in to vRealize Tenant App for VMware Cloud Director.
  2. Go to Administration -> Access management from the left panel.
  3. There will be a list of organizations along with a toggle button to enable/disable the plugin.
image.png
Note: The example has been taken from my lab.

       4. Disable the plugin for the organization that is having the issue and re-enable it.
       5. The plugin will start working as usual in the vCloud Director.