Editing a greyed out custom form on service broker on Aria Automation 8.x
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Editing a greyed out custom form on service broker on Aria Automation 8.x

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Article ID: 345947

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • To be able to edit the greyed-out custom form in the service broker.


Symptoms:
  • While trying to add a template to the existing blueprint, the custom form appears greyed out and does not allow editing.:
  • image.png
 


Cause

  • This is an expected behavior.

Resolution

  • Expected behavior but a workaround is available.


Workaround:

Follow the steps to be able to edit the existing custom form:

  1. Take Snapshot of vRA (Non-Memory)
  2. Login to service broker --> Go to content --> Open the form to be edited.
  3. Click Action and export the JSON format of the custom form.
  4. Make a copy of the Original JSON file and keep it as a backup.
  5. Update the copied JSON file with the required changes.
Example: Add label and it's value under the template section.
{"label":"AlmaLinux 8","value":"TEMPLATE-ALMA8"}
  1. Save the changes.
  2. Import the updated JSON file to the custom form.


Additional Information

Impact/Risks:

  • No Impact.

Additionally ,If you need to edit the Field ID in a custom form, you can do so by exporting the form as a JSON file, implementing the changes required, and then importing the updated JSON file.