Aria Automation deployments fail with Error: {"status":"500 INTERNAL_SERVER_ERROR","serverMessage":"Counter exhausted"}
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Aria Automation deployments fail with Error: {"status":"500 INTERNAL_SERVER_ERROR","serverMessage":"Counter exhausted"}

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Article ID: 345943

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Aria Automation deployments fail to provision with error:

{"status":"500 INTERNAL_SERVER_ERROR","serverMessage":"Counter exhausted"}


Environment

VMware Aria Automation 8.x

Cause

  • The issue occurs when the counter used for naming is exhausted.
For example if a naming policy is configured as '${NAME}-{##}' this will happen after 99 objects are deployed, for a naming policy of '${NAME}-{###}' this will be after 999 objects are deployed

Resolution

  • VMware are aware of the issue and a feature request has been opened to support the re-use of numbers and allow a reset of the naming feature's counter.


Workaround:
  • To workaround the issue delete and recreate the affected naming template.
  • When recreating the naming template consider using a larger counter value as per the documentation the maximum length of the number property in naming templates is 19 digits.