vSphere UI Client Plugin named N/A after vSphere 8 upgrade
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vSphere UI Client Plugin named N/A after vSphere 8 upgrade

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Article ID: 345917

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Trying to un-register and remove an incompatible plugin from our vCenter server appliance. Fails to remove after multiple attempts. Incompatible plug-in for removal: https://<server name>:443/ui/plugin-resources/h4va.zip

Environment

VMware vCenter Server 8.0

Cause

Upgrade of vCenter to 8.0. This is a default vCloud Availability plugin for vCloud Director with a vCenter Server deployment and it uses the deprecated local plugin architecture. This particular version of plugin is no longer applicable or compatible with vSphere 8.

Resolution

  1. SSH to the VCSA as root
  2. Use the Lookup Service utility (lstools.py) to find the service ID for the plugin you which to unregister by running the following command:
    /usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk --product com.vmware.h4
    You should get back only single response and make a note of the Service ID which is required in the next step.
  3. You can now unregister the plugin by providing the Service ID along with the administrator credentials by running the following command
    /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url http://localhost:7090/lookupservice/sdk --id <Service ID from previous step> --user [email protected] --password <PASSWORD>
  4. Finally, restart the vSphere UI Client service for the changes to take affect by running the following command:

service-control --restart vsphere-ui