How to handle when communication between applications and local appliance proxy hub failed in NSX manager
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How to handle when communication between applications and local appliance proxy hub failed in NSX manager

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Article ID: 345818

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: Alarm for communication.manager_control_channel_down
Event ID: communication.manager_control_channel_down
Added in release: 3.0.2
Alarm Description:
  • Purpose: Alarm is raised when no connectivity between appliaction and appliance proxy hub is found.
  • Impact: It would lead to various functionality failure which involves communication with daemons running on other NSX Managers and transport nodes. The following functionality issue can be seen:
    1. Intent would not be realized on transport nodes.
    2. Monitoring data such as status, stats and alarms would not be received from other Manager nodes and transport nodes.


Environment

VMware NSX-T Data Center

Resolution

Resolution:
Following steps can be executed for resolution:
1. Restart messaging manager /etc/init.d/messaging-manager restart.
2.On Impacted NSX Manager node restart local appliance proxy hub daemon with running command /etc/init.d/nsx-appl-proxy restart.
In case issue does not get resolved contact VMware support team.

Additional Information

All Alarm Trigger Conditions:
This Alarm will be raised when messaging communicaiton channel is down between messaging-manager and local appliance proxy hub in NSX Manager node.

Root cause analysis:
Alarm can be raised because of following reasons:
1. Check on impacted NSX Manager node whether the local Appliance Proxy Hub is running with command /etc/init.d/nsx-appl-proxy status.
2. If messaging connectivity between messaging-manager and local appliance proxy hub is down with running cmd zgrep -i onserverconnection /var/log/appl-proxy.* | grep framework