Service Insertion KB for the Deployment/Undeployment Alarms.
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Article ID: 345775
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Updated On:
Products
VMware NSX
Issue/Introduction
Customer should be able to gracefully solve the underlying conditions causing the alarm from the KB and then check if the workflow is working.
Symptoms: Service Deployment Failed Alarm, Service Undeployment Failed Alarm & SVM Health Status Down Alarm created with Service Insertion workflows.
Environment
VMware NSX 4.0.0.1
Cause
Service Deployment Failed Alarm: This could be caused if the OVF isn't available in the URL provided or there is a certificate validation failure that can cause deployments to fail.
SVM Health Status Down Alarm: Customer powers off the VM, or puts the Host in Maintenance Mode or customer uses the API to change the state of SVM
Service Undeployment Failed Alarms: This could be caused if the VM is deleted or the Host is in Maintenance Mode, or if there is an internal failure that fails in cleaning up the deployment objects
Resolution
Service Deployment Failed Alarm -> Delete the Service Deployment from the UI, and fix the underlying condition as reported in the alarm. Try Deployment again
SVM Health Status Down Alarm -> Find the SVM in VC and bring it back to the right state or use the API to put it back in the right state.
Service Undeployment Failed Alarm -> Contact the customer representative to clean off the service deployment objects using a custom script, this should clean up the failed Service Deployment deletio
Workaround: For all the Alarms, after fixing the error conditions, the Alarm should resolve itself automatically, if not then customer would have to manually resolve the alarm.