The VMware vCloud Director (vCD) UI access shows an error: HTTP ERROR: 503 Problem accessing /cloud/. Reason: Service Unavailable Powered by Jetty://
search cancel

The VMware vCloud Director (vCD) UI access shows an error: HTTP ERROR: 503 Problem accessing /cloud/. Reason: Service Unavailable Powered by Jetty://

book

Article ID: 345742

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

This article lists the detailed steps to fix the issues with VCD Transfer spooling area

Symptoms:
- DB Connection Issues
- Datastore which was hosting VCD Cell | DB VMs and the NFS server was inaccessible 
- Cannot verify the transfer space
- In the cell.log file, located at /opt/vmware/vcloud/director/logs/, you see entries similar to:

Application Initialization: 'com.vmware.vcloud.common.core' 100% complete. Subsystem 'com.vmware.vcloud.ui-vcloud-webapp' started
Application Initialization: 'com.vmware.vcloud.common.core' complete. Server is ready in 1:05 (minutes:seconds)
Successfully handled all queued events.
Error starting application: Transfer spooling area is not writable: /opt/vmware/vcloud-director/data/transfer

Environment

VMware Cloud Director for Service Provider 8.x
VMware Cloud Director for Service Provider 9.x

Cause

- This issue can occur post correcting the infrastructure issues the VCD Cell started before we initiated the DB Server or NFS server. Example: Post rectifying the datastore inaccessible .
- This issue can also occur if the if the table spaces fill up and the DBA’s have not allowed growth, or the Database server is simply down.  The transfer space issue is usually related to the mount point in FSTAB is missing or inaccessible

Resolution

Step 1: Validate the Database services are restored


- Involve the Database administrator to make sure that the database instance is up and running.
- Once the Database server is up restart the VCD Cell services using the following command:

service vmware-vcd start

Step 2: Validate Transfer Space Permissions and the mount point

$VCLOUD_HOME/opt/data/transfer.  vCloud DIrector creates a “vcloud” user and a “vcloud” group.  When you remount the transfer directory for NFS BOTH the UID and GID for “vcloud” must be set on the mount point.  If only one is it will affect the ability to validate the transfer space.  Note the group and user ownership below.  This must also be RECURSIVE on the sub folders as well.  Depending on the storage device you may need to query the GID and UID and give it to the storage folks for permissions.  If you have multiple cells NOT created from template you may have DIFFERENT GID’s and UID’s and you might want to edit them to be the same.

[root@vcdcell01 data]# ls -l
total 16
drwx------  3 vcloud vcloud 4096 Feb 07 07:30 activemq
drwx------  2 vcloud vcloud 4096 Feb 07  2010 generated-bundles
drwxr-x---+ 4 root root   33 Dec 23 09:17 transfer
drwx------  2 vcloud vcloud 4096 Dec 21 07:30 txlog

Update the permissions using the command: chown vcloud:vcloud transfer/

- Once the Transfer directory permissions are corrected, start the VCD Cell services using the following command:

service vmware-vcd start