During transforming workload cluster from V1 to V2 can choose duplicate records in the mongodb
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During transforming workload cluster from V1 to V2 can choose duplicate records in the mongodb

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Article ID: 345734

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Updated On:

Products

VMware VMware Telco Cloud Automation

Issue/Introduction

Symptoms:
- During transforming workload cluster from V1 to V2 can choose duplicate records in the mongodb with the cluster name or IP address and you want be able to instantiate CNF in the converted workload cluster.

-Unable to create k8s cluster with error endpoint ip 192.168.X.X has been used by workload cluster "cluster name"


Environment

VMware Telco Cloud Automation 2.1.1
VMware Telco Cloud Automation 2.1

Cause

This issue can occur due to duplicate entries arises during the cluster transformation from v1 to v2 in Telco cloud automation 2.1.x

Resolution

This issue is resolved in the Telco cloud automation 2.2.0

https://docs.vmware.com/en/VMware-Telco-Cloud-Automation/2.2/rn/vmware-telco-cloud-automation-22-release-notes/index.html#Resolved%20Issues


Workaround:

We need to remove duplicate entry from mongodb for v1 cluster and you will need to follow this steps:

On TCA-M appliance management UI verify that the cluster is show green.

On TCA-M mongodb operation:
1) SSH to the TCA-M
2) Connect to mongo :-> mongo hybridity
3) Check the VimStats Collection :->  db.VimStats.find().pretty()

4) Verify the above command output : look for "vimUrl" & "vimConnectionStatus" attributes.
5) For the vimUrl that is show as disconnected on TCA-M UI, verify that vimConnectionStatus is "connectionError" in the above output.
5) delete the stale entry :-> db.VimStats.remove({"vimUrl" : "<THE vimUrl Value>"}
)

for example :-> db.VimStats.remove({"vimUrl" : "https://10.10.10.10:6443"})
6) Repeat the same steps on TCA-CP.
7) Refresh the TCA-M UI to validate VIM is now shown as connected.