Tanzu Kuberenetes Grid Management cluster with AVI throws AkoDeploymentConfig error during the cluster creation.
search cancel

Tanzu Kuberenetes Grid Management cluster with AVI throws AkoDeploymentConfig error during the cluster creation.

book

Article ID: 345702

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • When creating the mgmt cluster with AVI, we can see the below error but cluster creation completes successfully.
error: unable to recognize “/tmp/kubeapply-3046101275": no matches for kind “AKODeploymentConfig” in version “networking.tkg.tanzu.vmware.com/v1alpha1”
: exit status 1, retrying
patch cluster object with operation status: 
{
“metadata”: {
“annotations”:

{ “TKGOperationInfo” : “

{\“Operation\“:\“Create\“,\“OperationStartTimestamp\“:\“2022-01-05 08:00:11.468329342 +0000 UTC\“,\“OperationTimeout\“:1800}
“,
“TKGOperationLastObservedTimestamp” : “2022-01-05 08:00:11.468329342 +0000 UTC”
}
}
}


Environment

VMware Tanzu Kubernetes Grid 1.x

Cause

This is a false alarm and known issue in TKGm 1.4

The problem is because tanzu cli deploys ADC(AKO Deployment config)  definition and ADC object when creating management cluster, but when tanzu cli applies ytt template, it doesn't have a certain order to follow, so when the object got applied first and definition applied last, then it will throw this error. But since the cli will retry, it will finally get everything applied as requested.

Resolution

This issue is resolved in TKGm 1.5