Changing the hard disk mode of a virtual machine fails with the error: Access to resource settings on the host is restricted to the server which is managing it
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Changing the hard disk mode of a virtual machine fails with the error: Access to resource settings on the host is restricted to the server which is managing it

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Article ID: 345685

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • When connected directly to an ESXi host managed in vCenter Server and attempt to change the virtual hard disk mode for a virtual machine the following error is seen:

    Access to resource settings on the host is restricted to the server '##.##.##.##' which is managing it

  • The following is seen on the ESXi host:

    Access to resource settings on the host is restricted to the server that is managing it: '##.##.##.##'


Cause

This behavior is by product design. There is a requirement that virtual machine changes must be performed while on a vSphere Client connected to vCenter Server.

Resolution

To resolve this issue, change the virtual hard disk mode for a virtual machine using the vSphere Client while connected to vCenter Server.

Note: If there is a requirement to change the virtual hard disk mode for a virtual machine when connected directly to an ESXi host, the vpxa agent must be offline on the host to do so.

To work around this issue:
  1. Connect to the target ESXi host via SSH or console and log in with the root account.
  2. Stop communication between the host and the vCenter Server by stopping these services with the commands:

    /etc/init.d/vpxa stop
    /etc/init.d/hostd restart

  3. Change the virtual hard disk mode on the target virtual machine.
  4. After completing the change, start the vpxa service to re-connect the ESXi host back to vCenter Server by running the command:

    /etc/init.d/vpxa start


Additional Information