"VMware Depot Not Available" error after upgrading from VMware Cloud Foundation 2.0.0 to 2.1.0
book
Article ID: 345628
calendar_today
Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
Symptoms: After upgrading VMware Cloud Foundation from version 2.0.0 to version 2.1.0, the Lifecycle Management page in the SDDC Manager UI displays the error:
VMware Depot Not Available
Environment
VMware Cloud Foundation 2.0.x VMware Cloud Foundation 2.1.x
Cause
This issue occurs when the cacerts file containing the VMware Depot certificate is not updated.
Resolution
This is a known issue affecting VMware Cloud Foundation 2.x.
Currently, there is no resolution.
To work around this issue:
Log in to the SDDC Manager virtual machine as the root user using SSH or the console.
The SDDC Manager virtual machine can be identified by it's name starting with "vrm-"
Stop all SDDC Manager services by running these commands:
service vrm-watchdogserver stop service vrm-tcserver stop service lcm-watchdogserver stop service lcm-init stop
Take a back up of the cacerts file by running this command:
Download the VMware Depot certificate file by running this command:
Note: If the SDDC Manager virtual machine does not have internet access, this command must be run on a Linux system with openssl installed that has internet access and the result vmwaredepot.crt file must be transferred to the /tmp directory on the SDDC Manager virtual machine.
Start all SDDC Manager services by running this commands:
service vrm-watchdogserver start service lcm-watchdogserver start
Additional Information
To be alerted when this article is updated, click the subscribe button [cid:[email protected]] . For more information on KB subscription features, see the Knowledge Base Article FAQs: How to Subscribe to VMware Knowledge Base Articles (76417).