Harbor deployment fails after manual/vSphere HA reboots the Harbor vm
search cancel

Harbor deployment fails after manual/vSphere HA reboots the Harbor vm

book

Article ID: 345613

calendar_today

Updated On:

Products

VMware Tanzu Kubernetes Grid

Issue/Introduction

Symptoms:
  • After manual reboot / vSphere HA reboot of Harbor VM, harbor UI does not work.

  • Bosh deployment status for harbor is showing as failed/failing.

  • Push or pull of images from the harbor is failing.



Environment

VMware Pivotal Container Service 1.x

Cause

This issue occurs due to a missing bosh-dns entry in /etc/resolv.conf after reboot or restart of the Harbor VM.

Resolution

This is a known issue affecting VMware Harbor 1.4.1 with VMware PKS.

This issue is set to be resolved in VMware Harbor 1.4.2 and later, available at Pivotal Network.


Workaround:

To work around this issue:

  1. ssh into Harbor VM by running the command:
    bosh ssh <harbor vm> -d <bosh deployment>

  2. To get elevated privileges, run sudo -i

  3. Run the bosh dns script by running the command:

    /var/vcap/jobs/enable-bosh-dns/bin/pre-start