Uploading helm chart from the Harbor GUI failed with error: Bad Gateway 502
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Uploading helm chart from the Harbor GUI failed with error: Bad Gateway 502

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Article ID: 345575

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Uploading helm chart from the Harbor GUI failed with error: Bad Gateway 502
  • Chartmuseum is in unhealthy state as below

harbor-app/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:~# curl -k https://harbor-fqdn/api/health

{

  "status": "unhealthy",

  "components": [

    {

      "name": "portal",

      "status": "healthy"

    },

    {

      "name": "jobservice",

      "status": "healthy"

    },

    {

      "name": "registry",

      "status": "healthy"

    },

    {

      "name": "registryctl",

      "status": "healthy"

    },

    {

      "name": "database",

      "status": "healthy"

    },

    {

      "name": "redis",

      "status": "healthy"

    },

    {

      "name": "chartmuseum",

      "status": "unhealthy",

      "error": "failed to check health: Get http://chartmuseum:9999/health: proxyconnect tcp: dial tcp x.x.x.x:3128: i/o timeout"

    },

    {

      "name": "core",

      "status": "healthy"

    }

  ]

 


Environment

VMware PKS 1.x

Cause

The issue is seen when proxy is enabled in the environment and Chartmuseum is not added to no-proxy list

Resolution

To resolve the issue, make sure all the below entry is added to Opsman > Harbor tile > Networking > No Proxy.

127.0.0.1,localhost,.local,.internal,log,db,redis,nginx,core,portal,postgresql,jobservice,registry,registryctl,clair-adapter,chartmuseum,notary-server

Once the entry is added, apply changes from opsmanager by selecting the harbor tile.