VMware Smart Assurance: NCM Installation fails with error "Failed to run $VOYENCE_HOME/tools/password-change.pl -s"
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VMware Smart Assurance: NCM Installation fails with error "Failed to run $VOYENCE_HOME/tools/password-change.pl -s"

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Article ID: 345330

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
NCM Install fails with below errors in Installation logs. 

$VOYENCE_HOME/logs/NCM-<Version>-install.log:
Execute Script/Batch file: AppServer.pl post-install (Unix)
                          Status: SUCCESSFUL

Custom Action:            com.zerog.ia.customcode.util.miscutils.ThrowInstallError
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class com.zerog.ia.customcode.util.miscutils.ThrowInstallError FatalInstallException: 

Execute Script/Batch file: AppServer.pl post-install lockboxoutput  (Unix)
                          Status: SUCCESSFUL


$VOYENCE_HOME/logs/NCM-<Version>-debug.log:
APPSERVER_POST_ERR=Note: Forwarding request to 'systemctl enable tomcat.service'.

Note: This output shows SysV services only and does not include native
      systemd services. SysV configuration data might be overridden by native
      systemd configuration.

      If you want to list systemd services use 'systemctl list-unit-files'.
      To see services enabled on particular target use
      'systemctl list-dependencies [target]'.

Redirecting to /bin/systemctl restart  httpd.service
Redirecting to /bin/systemctl restart  httpd.service
ERROR: Failed to run /data/smarts-ncm/tools/password-change.pl -s
 Please make sure Apache Service is up. If Apache is up, you might be seeing this error due to improper uninstallation of mod_nss. Please refer to the Documentation for further details. at AppServer.pl line 1713.

APPSERVER_POST_EXIT=2


Tomcat is up and running fine. Tried uninstall of NCM, reinstall of Apache httpd and installation of NCM, again facing the same issue.

Environment

VMware Smart Assurance - NCM

Cause

Navigate to $VOYENCE_HOME/tools directory in the installation and run below:
source /etc/voyence.conf
./password-change.pl -s

Unable to retrieve the password list from 127.0.0.1
Verify that Apache is running and that the certificates are correctly configured.


Take backup of file password-change.pl:
cp password-change.pl password-change.pl.orig

Opened the file password-change.pl and edit below lines from:
system($WGET." ".$ARGS." >$NUL 2>&1");
system($WGET." ".$ALT_ARGS." >$NUL 2>&1");


To:
system($WGET." ".$ARGS." ");
system($WGET." ".$ALT_ARGS." ");


Save and close the file.
Execute the file now:
./password-change.pl -s
--2020-04-28 09:46:07--  https://127.0.0.1/.pass.props
Resolving idcproxy.xxx.com (idcproxy.xxx.com)... 146.y.y.y
Connecting to idcproxy.xxx.com (idcproxy.xxx.com)|146.y.y.y|:80... connected.
Proxy tunneling failed: Service UnavailableUnable to establish SSL connection.
--2020-04-28 09:46:08--  https://127.0.0.1/.pass.props
Resolving idcproxy.xxx.com (idcproxy.xxx.com)... 146.y.y.y
Connecting to idcproxy.xxx.com (idcproxy.xxx.com)|146.y.y.y|:80... connected.
Proxy tunneling failed: Service UnavailableUnable to establish SSL connection.
Unable to retrieve the password list from 127.0.0.1
Verify that Apache is running and that the certificates are correctly configured.



This indicates that there is a proxy configured on the server, which is causing the issue of unable to establish SSL connection to the server self IP.

Resolution

Make sure that the server/VM doesn't have proxy configured. Contact system administrator for disabling the proxy configuration on the server.

Once the proxy configuration is removed, execute the edited password-change.pl, which should result connected.
After which NCM can be uninstalled and re-installed for successful completion.