Force mounting a LUN on an ESXi 5.x host fails with the error: duplicate extents found
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Force mounting a LUN on an ESXi 5.x host fails with the error: duplicate extents found

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Article ID: 345232

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Cannot force to mount a LUN with command esxcli storage vmfs snapshot mount -u VMFS_UUID on the ESXi host
  • Forcing to mount a LUN with command esxcli storage vmfs snapshot mount -u VMFS_UUID on the ESXi host fails
  • You see the error:

VMFS UUID/label: 5419946d-5e388324-04a4-020eb66da988/LUN01
Can mount: No (duplicate extents found)
Can resignature: No (duplicate extents found)
Extent name: eui.00255c3a2285016e:1 range: 0 - 547583 (MB)
Extent name: eui.00255c3a2285001a:1 range: 0 - 547583 (MB)

  • Any attempt to re-signature via the Add Storage wizard indicates of a complete format of the affected LUN


Environment

VMware vSphere ESXi 5.0
VMware vSphere ESXi 5.5
VMware vSphere ESXi 5.1

Cause

This issue occurs when two different LUNS with their own unique NAA ID and have the same VMFS signature.
 
For example:
 
VMFS UUID/label: 5419946d-5e388324-04a4-020eb66da988/LUN01
Can mount: No (duplicate extents found)
Can resignature: No (duplicate extents found)
Extent name: eui.00255c3a2285016e:1 range: 0 - 547583 (MB)
Extent name: eui.00255c3a2285001a:1 range: 0 - 547583 (MB)

Note:
 
eui.00255c3a2285001a was the original LUN
eui.00255c3a2285016e was the snapshot LUN

Resolution

To resolve this issue, perform these steps.
  1. Un-present one of the affected LUNs from the ESXi host. For more information, see Unmounting a LUN or detaching a datastore/storage device from multiple VMware ESXi 5.x hosts (2004605).
  2. Rescan all HBAs as required.
  3. Attempt to re-signature the other affected LUN. For more information, see vSphere handling of LUNs detected as snapshot LUNs (1011387).
  4. Present the other affected LUN on the same ESXi host. Confirm that this LUN is visible in the Storage Adapters device list. Rescan all HBAs as required.
  5. Attempt to re-signature the other affected LUN.

If the issue persists:



Additional Information