Upgrading vCenter Server 7.0 fails during the pre-check due to max session limit
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Upgrading vCenter Server 7.0 fails during the pre-check due to max session limit

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Article ID: 345200

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Upgrading to vCenter Server 7.0 fails during the pre-check with one of the following messages.
Failed to log in to Authorization service using the machine solution user. The user could have hit the max session limit.
Resolution: Check /var/log/vmware/vpxd-svcs/vpxd-svcs.log, Restart the vmware-vpxd-svcs service and retry. For further information see KB 81953
 
Exception occurred in install precheck phase
 
  • Within the /var/log/vmware/vpxd-svcs/vpxd-svcs.log file, it shows the session count reaching 200.
Session count for user [after add]: <DOMAIN_NAME>\machine-xxxx is 200
Session limit reached for user: <DOMAIN-NAME>\machine-xxxx with 200 sessions.

Note: This issue is most often seen during upgrades, though it is possible to encounter it in other situations. It has also been observed to create delayed responses while interacting with the Web Client and loading the vCenter inventory. The messages above will help confirm if the vCenter has encountered this issue.

Environment

VMware vCenter Server 7.0.x

Cause

This issue occurs when the session limit of 200 in the vCenter Authorization (AuthZ) service is reached.

Resolution

Depending on the message seen in the UI, the workaround for this issue will vary slightly.


Message: Failed to log in to Authorization service using the machine solution user. The user could have hit the max session limit.

This message is seen before starting the install. To workaround it, restart the vpxd-svcs service on the original vCenter Server Appliance and retry the upgrade.

  1. From an SSH session to the vCenter Server Appliance, run the command:
    service-control --restart vmware-vpxd-svcs
  1. Reattempt the upgrade


Message: Exception occurred in install precheck phase

This message is seen during the install phase. The workaround steps depend on if the Resume button is available in the installer UI.

Resume button available:

  1.  From an SSH session to the vCenter Server Appliance, run the command:
service-control --restart vmware-vpxd-svcs
  1. Return to the Installer UI and press the Resume button
Resume button is not available:
  1. Restore the vCenter Server from a snapshot or backup.
  2. Restart the vpxd-svcs service.
  3. Reattempt the upgrade.


Additional Information

Refer to release notes : vSphere 7.0 u1c release notes

Impact/Risks:
No impact.