uiClient.txt not created in client machine instances
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Article ID: 345110
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
uiClient.txt log missing/not available in C:\Users\<username>\VoyenceControl\logs\NCM_INSTANCE_IP\ in NCM 10.1.6 instance.
Environment
NCM - 10.1.6
Cause
VMware Smart Assurance NCM development team has identified the issue with uiClient.txt not being generated in a few 10.1.6 deployments, this behavior has been fixed in NCM 10.1.8 release.
Resolution
Please consider upgrading NCM 10.1.6 instances to 10.1.8 release if uiClient.txt is not created under directory C:\Users\username>\VoyenceControl\logs\NCM_INSTANCE_IP\ in NCM 10.1.6 instance.
Workaround: Users can follow below instructions to ensure client related information/logs is generated in NCM 10.1.6 environment (instances on which uiClient.txt is not available in path C:\Users\<username>\VoyenceControl\logs\NCM_INSTANCE_IP\):
Go to Java Control Panel in Windows client, Click Advanced, Under Debugging, check "Enable tracing", and "Enable logging"
Clear the java cache, please navigate to General under Java Control Panel, Settings, Delete Files…, check all, and select Ok.
After step 2, login normally to NCM UI, reproduce the issue, and once the issue has been observed, navigate to C:\Users\Administrator\AppData\LocalLow\Sun\Java\Deployment\ and share the log folder.
The above path could be different in the user's case due to a different username but in general, it's present under <User Application Data Folder>\Sun\Java\Deployment\log on a Windows machine.
The above mentioned log folder will have all the logging details from the client, which would help in debugging NCM GUI related issues.