VMware Smart Assurance NCM: Error "<Resource Not Found>" is thrown in NCM 10.1.6 GUI while operating on device classes under Global
search cancel

VMware Smart Assurance NCM: Error "<Resource Not Found>" is thrown in NCM 10.1.6 GUI while operating on device classes under Global

book

Article ID: 345103

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

Error "<Resource Not Found>" is thrown in newly installed NCM 10.1.6 distributed setup while operating on device classes under Global in GUI.

Image_A.png

Image_B.png


Environment

VMware Smart Assurance - NCM

Cause

Permissions/Ownership issue in $VOYENCE_HOME/data/appserver/pops/ directory after new NCM 10.1.6 distributed setup installation. This is determined by reviewing $VOYENCE_HOME/logs/daemon.log in application server wherein following error with regards to "popxxxx" is seen:

DEBUG [com.powerup.configmgr.deviceservice.rmi.DeviceClassConfigurationManagerImpl] (RMI TCP Connection(271)-xx.xx.xx.xx) setGlobalDeviceClassConfiguration
DEBUG [com.powerup.configmgr.deviceservice.rmi.DeviceClassConfigurationManagerImpl] (RMI TCP Connection(271)-xx.xx.xx.xx) Obtained device servers
ERROR [com.powerup.configmgr.deviceservice.rmi.DeviceClassConfigurationManagerImpl] (RMI TCP Connection(271)-xx.xx.xx.xx) Failed to write file - /opt/smarts-ncm/data/appserver/pops/pop1000/configuration/network_GLOBAL.xml
java.io.FileNotFoundException: /opt/smarts-ncm/data/appserver/pops/pop1000/configuration/network_GLOBAL.xml (Permission denied)

Resolution

The below steps are to be implemented if reported error is seen in GUI and corresponding permission denied error pertaining to $VOYENCE_HOME/data/appserver/pops/ directory is logged in daemon.log in application server: 

A) Default NCM 10.1.6 installation suggests ownership of "ncm:voyence" assigned to $VOYENCE_HOME/data/appserver/pops/ directory. Users can review ownership alignment in application/device server and assign permission “ncm:voyence” to popxxxx folder and its subfolders with command “chown -R "ncm:voyence" popxxxx" accordingly. 

B) Command "service vcmaster restart" and "service voyence restart" should be executed in application and device server respectively if step A) is implemented. 

C) Operations on device classes in GUI can be continued without reported "<Resource Not Found>" error being thrown anymore.