PTP Reporting Incorrect Date/Time.
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PTP Reporting Incorrect Date/Time.

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Article ID: 345061

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

To patch a flaw in linuxptp versions < 3.1.1.5 where the date/time is reported to be 1970.


Symptoms:

PTP anomalies in certain environments such as date being reported as 1970.


Cause

When using the LLS-C3 PTP configuration and when the Cell Site Router (CSR) is rebooted the CSR reports an incorrect time of 1970 in its PTP packets with clock class 248, and for a brief duration with clock class 6, until the CSR GNNS receiver enters the phase locked state. This incorrect time of 1970 that is advertised by the CSR is consumed by the linuxptp stack running on the nodepool and the phc_ctl time gets set to 1970.

Resolution

linuxptp 3.1.1-5 has been released with fixes to linuxptp. The functionality implemented in the patch is to ignore the PTP packets from the CSR when the PTP packets are sent with a clock class higher than what is configured in the ptp4l.conf file on the nodepool/worker node. When the CSR reboots, it can take up to 10 minutes for the CSR to go to a phase locked state. During this time, the PTP packets sent by the CSR to the nodepool with clock class 248 are ignored.

Note: These steps should be performed during a maintenance window.

Confirm availability of linuxptp 3.1.1-5

  1. Run this command to confirm linuxptp 3.1.1-5 is available on worker node:
    tdnf list | grep linuxptp

Update the CSAR

  1. Log into the TCA UI via your browser.

  2. In the UI, navigate to Catalog > Network Function.

  3. Click on the appropriate network function, then click Edit.

  4. Navigate to Infrastructure Requirements > Custom Packages.

  5. Update the linuxptp version field to reflect the new version (3.1.1-5.ph3)

    image.png
    Note: the above screenshot is only an example. Edits will need to be performed on the xNF CSAR (DU/CU) in your environment.

  6. On the top of the same page, click on Resources.

  7. Expand the folder Artifacts > scripts.

  8. Click on ptp4l.conf.

  9. Add clock_class_threshold 7 at the bottom, as shown below:

    # Clock Description
     
    #productDescription ;;
    revisionData ;;
    manufacturerIdentity 00:00:00
    userDescription ;
    timeSource 0xA0
    domainNumber 24
    clock_class_threshold 7

    [ptp]

  10. Click SAVE AS NEW

    Note: This is because there may already be CNFs deployed with the old configuration. We will upgrade them in a later step.

  11. Provide a name and Description (optional) and then click SAVE.

Upgrade the CNFs

  1. In the UI, navigate to Inventory > Network Function.

  2. Click the three dots next to the NF > Upgrade Package.

  3. Select the package we created in the previous step.

  4. Click UPGRADE.
    Note: the nodepool will be rebooted and the new
    linuxptp package will be applied
    .



Additional Information

If the CNF upgrade fails, login to the worker node and gather the below information to share with the support team.

  1. Establish an SSH session to the worker node.

  2. Run the following command to verify the new linuxptp package is installed and ptp4l.conf is updated:
    root [ /home/capv ]# tdnf list installed | grep linuxptp
    linuxptp.x86_64             3.1.1-5.ph3             @System

  3. Run the following commands to check if the ptp4l service and phc2sys services are running:
    systemctl status ptp4l
    systemctl status phc2sys

  4. From the worker node, check the ptp4l.conf file to ensure the config clock_class_threshold 7 is present.
    root [ /home/capv ]# cat /etc/ptp4l.conf | grep -B 8 clock_class_threshold
    # Clock Description
    #productDescription ;;
    revisionData ;;
    manufacturerIdentity 00:00:00
    userDescription ;
    timeSource 0xA0
    domainNumber 24
    clock_class_threshold 7



Impact/Risks:

All versions of VMware Telco Cloud Automation (TCA) are impacted.