HCX Compute Profile CPU/MEM Reservation Fails
search cancel

HCX Compute Profile CPU/MEM Reservation Fails

book

Article ID: 344988

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Inform Users on a known issues when setting CPU Reservation via HCX compute profile.

Symptoms:
User may run into an issue when trying to set CPU/MEM reservation at values greater than 90%.The appliance deployment tasks will fail with the below error. 


HCX UI:
1/22/24, 5:17 PM - Service Mesh modification failed. Process Service Mesh failed. Updating appliance reservation failed for user [email protected]. Reason: The host does not have sufficient CPU resources to satisfy the reservation. id : host-217038 Updating appliance reservation failed for user [email protected]. Reason: The host does not have sufficient CPU resources to satisfy the reservation. id : host-1014 Updating appliance reservation failed for user [email protected]. Reason: The host does not have sufficient CPU resources to satisfy the reservation. id : host-1017 

 

HCX-Connector app.log
2024-01-23 00:16:53.837 UTC [InterconnectService_SvcThread-51224, IX:e259f160-0784-458a-8f48-6674944bf4f8, J:14af5d88, , TxId: 01e54e4e-6e88-4a7c-b6ec-cff5225e3a5f] ERROR c.v.v.h.s.i.UpdateApplianceReservation- Error while updating virtual machine reservation for vm-217122 
2024-01-23 00:16:53.837 UTC [InterconnectService_SvcThread-51224, IX:e259f160-0784-458a-8f48-6674944bf4f8, J:14af5d88, , TxId: 01e54e4e-6e88-4a7c-b6ec-cff5225e3a5f] ERROR c.v.v.h.s.i.UpdateApplianceReservation-  Updating appliance reservation failed for user [email protected]. Reason: The host does not have sufficient CPU resources to satisfy the reservation. id : host-217038 java.lang.RuntimeException: (vim.fault.InsufficientHostCpuCapacityFault) {    faultCause = null,    faultMessage = (vmodl.LocalizableMessage) [       com.vmware.vim.binding.impl.vmodl.LocalizableMessageImpl@24500b39    ],    host = ManagedObjectReference: type = HostSystem, value = host-217038, serverGuid = null,    unreserved = 14100,    requested = 16000 

 


Cause

There is an issue that has been identified in the HCX deployment workflow and how it determines available CPU/MEM resources per host.

Resolution

Setting the CPU reservation below 90% will usually succeed. It all depends on the available resources on the ESXi hosts throughout the cluster. 

The best way to see what resources are available is to view the "CPU Reservation Details" in vCenter.
  • In VC UI click on the cluster --> Monitor --> Under "resource Allocation" click on CPU
  • The "available Reservation" value is for the entire cluster. Divide that by number of hosts. 
To pull the exact reservation available for any given host you can navigate to the host MOB. 

https://esxi1.gsslabs.org/mob/?moid=ha-root-pool&doPath=config.cpuAllocation
NOTE: Please substitute actual hostname in the above. 

Host MOB may be disabled. To enable create and/or set the below value to true:
Config.HostAgent.plugins.solo.enableMob          true 

HCX uses the below calculation to set reservation:
CPU reservation: 8 * 2000 * 100/100 = 16000
8= number of Logical Processers on ESXi host
2000= Processor Speed in MHZ 
100/100 = Reservation value over max reservation (100)

* If reservation set to 95% it would be 95/100




Workaround:
In most cases setting the reservation value to <90% should allow deployment to complete. 

OR 

Leave reservation set to 0

Additional Information

Impact/Risks:
Unable to deploy HCX appliances with 90% or above CPU/MEM reservation.