Logging in to the vSphere Web Client fails with the error: An internal error has occurred - Index '0' specified is out of bounds
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Article ID: 344874
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Updated On:
Products
VMware vCenter ServerVMware vSphere ESXi
Issue/Introduction
Symptoms:
The vSphere environment is running on 6.0 Update 1.
Logging in to the vSphere Web Client fails with the error:
Index '0' specified is out of bounds.
In the vsphere_client_virgo.log file, you see the entries:
[2016-03-16T13:19:52.510Z] [INFO ] fs-watcher org.eclipse.virgo.medic.eventlog.default DE0004I Starting bundle 'com.vmware.vsphere.client.telemetryservice' version '6.0.0'. ..... [2016-03-16T13:19:53.093Z] [ERROR] region-dm-6 c.v.ph.client.common.extensions.ps.DefaultProxySettingsValidator Error while validating proxy ProxySettingsWithOrigin[ ] java.net.UnknownHostException: vcsa.vmware.com: Name or service not known ..... [2016-03-16T13:25:07.360Z] [ERROR] Thread-30 com.vmware.vise.extensionfw.impl.PackagesDeployer Error deploying one of more bundles for the plugin package /usr/lib/vmware-vsphere-client/plugin-packages/vsphere-client java.lang.Exception: Timed out waiting for bundle to start: Bundle: id:com.vmware.vsphere.client.telemetryservice, version:6.0.0, contextPath:plugins, location:/usr/lib/vmware-vsphere-client/plugin-packages/vsphere-client/plugins/telemetry-service-6.0.0.jar, exportPackage:null, importPackage:null, isSorted:true at com.vmware.vise.extensionfw.impl.HotDeployBundleDeployer.deploy(HotDeployBundleDeployer.java:155) at com.vmware.vise.extensionfw.impl.PackagesDeployer.deployInternalPlugins(PackagesDeployer.java:198) at com.vmware.vise.extensionfw.impl.PackagesDeployer.deployPackage(PackagesDeployer.java:133) at com.vmware.vise.extensionfw.impl.PackagesDeployer.deploy(PackagesDeployer.java:78) at com.vmware.vise.extensionfw.ExtensionManager.addPluginPackages(ExtensionManager.java:419) at com.vmware.vise.extensionfw.impl.ExtensionBundleActivator$PluginActivatorThread.run(ExtensionBundleActivator.java:95)
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
The log file is located at:
WIndows vCenter Server:%ALLUSERSPROFILE%\VMWare\vCenterServer\logs\vsphere-client\logs
vCenter Server Appliance: /var/log/vmware/vsphere-client/logs
Cause
This issue occurs due to the Customer Experience Improvement Plugin that was introduced in vCenter Server 6.0 Update 1.
Back up the contents of C:\Program Files\VMware\vCenter Server\virgo\server\pickup\.
Remove the contents of the pickup directory by running:
del "C:\Program Files\VMware\vCenter Server\virgo\server\pickup\*" /q
Back up these files located in C:\Program Files\VMware\vCenter Server\WebClient\plugin-packages\vsphere-client\plugins\:
The files contained in this folder are:
telemetry-service-6.0.0.jar
telemetry-ui-war-6.0.0.war
phonehome-collector-ui-war-6.0.0.war
cis-data-service-cmc-6.0.0.jar
Remove these files from C:\Program Files\VMware\vCenter Server\WebClient\plugin-packages\vsphere-client\plugins\:
telemetry-service-6.0.0.jar
telemetry-ui-war-6.0.0.war
phonehome-collector-ui-war-6.0.0.war
cis-data-service-cmc-6.0.0.jar
Start the vSphere Web Client with these commands:
net start vspherewebclientsvc net start vmware-perfcharts
vCenter Server Appliance
Note: This procedure removes the Customer Experience Improvement Program Plugin.
To work around the issue in a vCenter Server Appliance:
Open an SSH session with the vCenter Server Appliance. For more information, see the Enable or Disable SSH and Bash Shell Access section in the vCenter Server Appliance Configuration guide.
Stop the vSphere Web Client service with this command:
service vsphere-client stop
Back up the contents of /usr/lib/vmware-vsphere-client/server/work/.
Remove the contents of the vSphere Web Client work directory by running this command: