(/var/log/vmware/vcf/lcm/lcm-debug.log)ERROR [vcf_lcm,27ac5a10ffcd0a13,8862,auditId=########-####-####-989f-1ff78b0ecb8a,resourceType=NSX_T_MANAGER,resourceId=nsx-mgmt-1.#####.vsphere.local,name=nsx-mgmt-1.####.vsphere.local] [c.v.e.s.l.p.impl.nsxt.NsxtAuditImpl,pool-6-thread-1] Error auditing NSX-T Cluster nsx-mgmt-1.####.vsphere.local with exception {}com.vmware.evo.sddc.lcm.model.error.LcmException: Failed to load NSX-T Cluster from the Inventory at com.vmware.evo.sddc.lcm.primitive.impl.nsxt.NsxtInventoryLoader.loadNsxtInventory(NsxtInventoryLoader.java:87) at com.vmware.evo.sddc.lcm.primitive.impl.nsxt.NsxtAuditImpl.doAudit(NsxtAuditImpl.java:68)Caused by: java.lang.RuntimeException: [address] nsx-mgmt-1:Validation failed. FQDN value does not match valid FQDN pattern at sun.reflect.GeneratedConstructorAccessor9128.newInstance(Unknown Source) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:423)VMware Cloud Foundation 4.3
VMware Cloud Foundation 4.2
Login to NSX-T manager via SSH and run following commands as "admin" user.
Substitute values for commands as per your environment.
nsx-mgmt-1> get hostnamensx-mgmt-1nsx-mgmt-1> set hostname nsx-mgmt-1.####.vsphere.localnsx-mgmt-1> get hostnamensx-mgmt-1.####.vsphere.localnsx-mgmt-1> rebootAre you sure you want to reboot (yes/no): yes