'PSC Service Health Alarm' on the vCenter
search cancel

'PSC Service Health Alarm' on the vCenter

book

Article ID: 344814

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • PSCHealth status changes from green to red in the vCenter alarm 



  • Similar entries in /var/log/vmware/messages: 

    YYYY-MM-TTTHH:MM:SS VCSA lsassd[#####]: #x############:Failed to sync system time [error code: #####]
    YYYY-MM-TTTHH:MM:SS VCSA systemd[1]: Time has been changed
    YYYY-MM-TTTHH:MM:SS VCSA CROND[#####]: (root) CMD ( /usr/sbin/iiad.sh >/dev/null 2>&1)
    YYYY-MM-TTTHH:MM:SS VCSA cli: twisted "127.0.0.1" - - [##/Jan/####:##:##:## +####] "POST /api HTTP/1.1" ### #### "-" "vAPI http client"
    YYYY-MM-TTTHH:MM:SS VCSA systemd[1]: Time has been changed

  • In /var/log/vmware/vmon/vmon.log, you see messages similar to:

    YYYY-MM-TTTHH:MM:SS warning vmon  Service pschealth exited unexpectedly. Crash count 1. Taking configured recovery action.
    YYYY-MM-TTTHH:MM:SS warning vmon  Service pschealth exited unexpectedly. Crash count 2. Taking configured recovery action.

Environment

VMware vCenter Server 6.0.x

VMware vCenter Server 7.0.x

VMware vCenter Server 8.0.x

Cause

This issue occurs if there is a time sync problem in vCenter Server.

Resolution

A time mismatch in vCenter is the root cause of this issue. To clear the alert, configure the vCenter Appliance Time Synchronization to sync with either an NTP server or the ESXi host.

 

Note: If you choose to sync vCenter time with an ESXi host, ensure that the host is already configured to synchronize its time with an external NTP source.

See the following documentation for configuring NTP within a vCenter Server/Appliance and ESXi host. 

Configure the System Time Zone and Time Synchronization Settings

Configuring Time Synchronization Settings in vCenter Server

Configure Network Time Protocol (NTP) for ESXi