VxRail upgrade task in SDDC Manager displays incorrect status
search cancel

VxRail upgrade task in SDDC Manager displays incorrect status

book

Article ID: 344784

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • This is an informational KB to let customers know that this is a known issue.
     


Symptoms:
  • The VxRail upgrade task status in SDDC Manager is displayed as running even after the upgrade is complete (success or failure) or VX Manager is in non-responsive state.


Environment

VMware Cloud Foundation 4.2

Cause

  • Upgrade task hung due to pgsql partition full on the VxRail manager

Resolution

  • This is a known issue and currently there is no resolution


Workaround:
  • Workaround this issue by restarting the LCM service
  • Check that VxManager is responsive
    1. Login to SDDC Manager VM via SSH
    2. Run following API to verify VxManager status:
curl -k -u "SSO_USER_NAME:SSO_USER_PASSWORD" https://<VX_MANAGER_FQDN>/rest/vxm/v1/system
  • Please contact DELL support if VxManager API is not responding.
  • If API is responsive then proceed with remaining steps to restart LCM service:
    • Login to SDDC Manager VM via SSH and switch to root
    • Run the following command to restart LCM:
      • systemctl restart lcm
    • Wait for LCM to restart 
    • Run the following command to verify that LCM service is up and running
      • systemctl status lcm
The task status will be synchronized
Retry VxRail upgrade from SDDC Manager UI if it is marked as failed.