Virtual machine options are grayed out in vSphere Client
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Article ID: 344709
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Updated On:
Products
VMware vCenter ServerVMware vSphere ESXi
Issue/Introduction
This article provides troubleshooting steps when virtual machine options are grayed out in vSphere Client.
Virtual machine operations are grayed out
Unable to perform operations on the virtual machine
Menu options are grayed out when the virtual machine is right-clicked
There is an error message:
Another task in progress
Cause
This issue occurs when:
Permissions are not set correctly
There are virtual machine tasks running in the background
The .vmx file is corrupted.
There are invalid arguments in the .vmx file.
Resolution
Note: The virtual machine must be powered off to edit the .vmx file as required.
Permissions Are Not Set Correctly
Ensure there are sufficient permissions on the virtual machine.
In the vSphere Client, select the virtual machine.
Click the Permission tab.
Ensure that sufficient permissions are applied to the user/group.
If permissions are defined at a host, cluster, datacenter or vCenter level, apply the required permissions to the user or group to edit the virtual machine settings.
Virtual Machine Tasks are Running in the Background
Virtual machine tasks that cannot be seen in the vSphere Client Tasks & Events tab or in the Recent Tasks pane may be running in the background.
To check if other virtual machine tasks are running in the background:
Log into the ESXi host using SSH or on the console.
List all registered virtual machines:
vim-cmd vmsvc/getallvms
Note: Make note of the vmid for the problem virtual machine.
Check running tasks on the virtual machine:
vim-cmd vmsvc/get.tasklist vmid
Note: If a task is running on that virtual machine, the output will list the tasks. For example: