Error on VM : "Object has already been deleted or has not been completely created"
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Error on VM : "Object has already been deleted or has not been completely created"

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Article ID: 344679

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Error while migrating the VM or reverting a snapshot: "The object 'vim.VirtualMachine:vm-abc' has already been deleted or has not been completely created"

  • Reverting to a snapshot in vCenter Server fails with the error:
    This object has already been deleted or has not been completely created.
  • Unable to power on or migrate a cloned virtual machine.
  • In the location less /var/log/vmware/vpxd/vpxd.log inx vCenter Server logs, you see entries similar to:
    'App' opID=3DB842F7-0000xxxx] [VpxLRO] -- ERROR task-48xxxx -- <vm-moid> -- vim.vm.Snapshot.revert: vmodl.fault.ManagedObjectNotFound:
    134ab-Result:
    134ab-(vmodl.fault.ManagedObjectNotFound) {
    134ab- dynamicType = <unset>,
    134ab- faultCause = (vmodl.MethodFault) null,
    134ab: obj = 'vim.vm.Snapshot:<snapshot-moid>',
    134ab- msg = "",

     

  • In the location  less /var/run/log/hostd.log on esxi , you see entries similar to:
     F4F51B90 info 'Vmomi'] Throw vmodl.fault.ManagedObjectNotFound
    F4F51B90 info 'Vmomi'] Result:
    (vmodl.fault.ManagedObjectNotFound) {
    dynamicType = <unset>,
    faultCause = (vmodl.MethodFault) null,
    obj = 'vim.vm.Snapshot:<snapshot-moid>',
    msg = "",
    }

Environment

VMware vSphere 8.0.x
VMware vSphere  7.0.x
VMware vSphere 6.0.x

Cause

This issue occurs due to a mismatched snapshot object id in vCenter Server database. The mismatch can be triggered by migrating the powered off virtual machine to a different ESXi host then restarting the vpxd service.

Resolution

  1. Restart hostd and vpxa service on the ESXi host where the problematic VM is residing .
  2. Re-register the VM 

    Note: If the problem still exists after trying the steps in this article:

    File a support request with Broadcom Support. For more information, see Creating and managing Broadcom support cases.