In the vpxd-profiler-xx.log it shows high number of API calls "waitForUpdates" and total number of sessions from client software.
Note:The preceding log excerpts are only examples, date, time and environmental variables will vary depending on your environment.
Environment
VMware vCenter Server 6.7.x VMware vCenter Server Appliance 6.5.x VMware vCenter Server Appliance 6.7.x VMware vCenter Server Appliance 6.0.x VMware vCenter Server 6.0.x VMware vCenter Server 6.5.x
Cause
Client software is using deprecated waitForUpdates calls instead of waitForUpdatesEx calls. Using the deprecated API by client software is causing timing out before the waitForUpdates calls are completing. Use of waitForUpdatesEx will allow introduction of a timeout smaller than the one used by the client or firewall.
Resolution
This is not a VMware bug. Please contact the 3rd party client software vendor for the fix.
Workaround: To workaround: 1. Disable or remove the Client software plugin. For mor details on steps refer to VMware KB 2. Once the user account/offending IP is determined, take steps to avoid making API waitForUpdates call.