VMware vCenter Update Manager patch download task fails to complete
search cancel

VMware vCenter Update Manager patch download task fails to complete

book

Article ID: 344663

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • The patch download task in VMware vCenter Update Manager fails to complete.
  • The patch download task remains in the In Progress status.
  • In environments with virtual appliances, after a restart of the Update Manager server, the Update Manager update download task remains indefinitely in the In Progress state.
  • The Details column in the Recent Tasks pane shows:

    scanning virtual appliances


Environment

VMware vCenter Update Manager 5.0.x
VMware ESX 4.0.x
VMware ESXi 4.1.x Installable
VMware ESX 4.1.x
VMware ESXi 4.0.x Embedded
VMware ESXi 4.0.x Installable
VMware vSphere ESXi 5.0
VMware vCenter Update Manager 5.1.x
VMware vCenter Update Manager 4.1.x
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.5
VMware vCenter Server 4.1.x
VMware vCenter Update Manager 5.5.x
VMware ESXi 4.1.x Embedded
VMware vSphere ESXi 5.1

Cause

This issue occurs if Update Manager is unable to complete a scan against a virtual appliance.

Resolution

This issue is resolved in VMware vCenter Server 4.1 Update 2, available at VMware Downloads. and modules released on 2011-10-27. For further information see the Resolved Issues section in the vCenter Server 4.1 Update 2 Release Notes.

To work around this issue:
When system is using Capacity IQ:
  1. Shut down the CapacityIQ virtual appliance.
  2. Stop the Update Manager service. If the service fails to shutdown, stop the vmware-updatemgr.exe process in Task Manager.
  3. Start the Update Manager service. For more information, see Stopping, starting, or restarting the vSphere Update Manager service (1039328).
Notes:

When system is not using Capacity IQ:
  1. Connect to the vCenter Server machine using Remote Desktop and an administrative user.
  2. Open the vci-integrity.xml file using a text editor.
  3. Search for the section <disableValm>false</disableValm> and change the setting to true.

    For example:

    <disableValm>true</disableValm>

  4. Restart the VMware Update Manager service. For more information, see Stopping, starting, or restarting the vSphere Update Manager service (1039328).


Additional Information

Stopping, starting, or restarting the vSphere Update Manager service
The Update Manager task Discovering Virtual Appliance never completes