Windows 仮想マシン上の VMware Tools が次のエラーで失敗する: Exception 0xc0000005 (access violation)
search cancel

Windows 仮想マシン上の VMware Tools が次のエラーで失敗する: Exception 0xc0000005 (access violation)

book

Article ID: 344487

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

免責事項: これは英文の記事 「VMware Tools on a Windows virtual machine fails with the error: Exception 0xc0000005 (access violation) (2012572)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • ESX/ESXi ホスト上で実行されている Windows 仮想マシンで VMware Tools をアップグレードした後に、VMware Tools サービスが繰り返し失敗する。
  • 次のエラーが表示される。

    VMware Tools のリカバリ不能なエラー: (vthread-3)
    例外 0xc0000005(アクセス違反)が発生しました。
    コア ファイルは
    「C:\Windows\system32\config\systemprofile\AppData\Roaming\VM\vm
    toolsd-4612.dmp」で使用できます。サポートに問い合わせ、コア ファイルの内容を送信することができます。
    VMware サポートに提出するデータを収集するには、[ヘルプ] メニュー
    から [サポートデータの収集] を選択してください
    または Workstation フォルダ内の「vm-support」スクリプトを直接実行してください。
    当社はお客様のサポート資格に基づいて対応します。


Environment

VMware ESX 4.1.x
VMware ESXi 4.0.x Installable
VMware ESXi 4.1.x Embedded
VMware vSphere ESXi 5.1
VMware ESXi 4.1.x Installable
VMware ESXi 4.0.x Embedded
VMware vSphere ESXi 5.0
VMware ESX 4.0.x

Cause

この問題は、複数のバージョンの共有 DLL ファイルが存在する場合に発生します。

たとえば、デフォルトでは、VMware Tools ビルド 381511 の hgfsUsability.dll DLL ファイルは C:\Program Files\VMware\VMware Tools\plugins\vmsvc\ にインストールされます。この .dll ファイルのバージョンは 8.3.7.4937 です。

ESXi 5.0 ホストの VMware Tools ビルドにアップグレードする場合、ファイルの hgfsUsability.dll C:\Program Files\VMware\VMware Tools\plugins\common\ にインストールされ、.dll ファイルのバージョンは 8.6.0.6261 です。
VMware Tools のアップグレード プロセスでは、古いバージョンの DLL ファイルの削除を試みますが、場合によっては、DLL が権限関連の問題か、または Windows オペレーティング システム上のカスタム ユーザーの変更のために削除されない場合があります。

Resolution

この問題を解決するには、同じ名前だが異なるバージョンの複数の DLL ファイルがシステム上に存在していないかどうかを確認して、存在していた場合は古いバージョンの DLL を削除する必要があります。

古いバージョンが存在していないかどうかを確認して、存在していた場合にその DLL を削除するには、次の手順を実行します。
  1. VMware Tools でデバッグ ログを有効にします。詳細については、「Enabling debug logging for VMware Tools within a guest operating system (1007873)」を参照してください。
  2. VMware Tools サービスを開始して、ログをキャプチャします。

    このサービスを開始するには、次の手順を実行します。
    1. スタート > ファイル名を指定して実行 をクリックし、「services.msc」と入力して OK をクリックします。[サービス] ウィンドウが開きます。
    2. VMware Tools Service を見つけて右クリックして、開始 をクリックします。

  3. VMware Tools のログ ファイルを検索して、同じ名前だが異なるバージョンの DLL ファイルを探します。

    :ログ ファイルの場所は、手順 1 で設定したパスです。

  4. 古いバージョンの DLL ファイルを削除するか、その DLL をオペレーティング システムから登録解除します。

    DLL を登録解除するには、Windows システムのコマンド プロンプトで次のコマンドを実行します。

    regsvr32 /u filename.dll

  5. 仮想マシンを再起動します。これで、VMware Tools は正しく起動するはずです。
上記の手順を実行しても問題が解決しない場合は、「Unable to upgrade existing VMware Tools (1001354)」を参照してください。

問題が解決しないか、または問題のある DLL の隔離がうまくいかない場合は、VMware サポートに連絡してサポート リクエストを提出してください。詳細については、『How to File a Support Request』を参照してください。


Additional Information

詳細については、VMware コミュニティのスレッド「Exception 0xc0000005 (access violation) has occurred when starting VM」を参照してください。VMware Tools on a Windows virtual machine fails with the error: Exception 0xc0000005 (access violation)