Update Manager service fails immediately after it is started
search cancel

Update Manager service fails immediately after it is started

book

Article ID: 344205

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • The VMware Update Manager service fails immediately after it is started
  • The Update Manager service fails immediately after initialization, resulting in a dump of the process.
  • In the vmware-vum-server-log4cpp.log file (located in the Update Manager log directory at C:\Documents and Settings\All Users\Application Data\VMware\Update Manager or C:\Users\All Users\VMware\VMware Update Manager\Logs), you see entries similar to:

    [2011-07-07 12:32:32.695 09652 info 'App'] CoreDump: Writing minidump
    [2011-07-07 12:32:32.850 09652 panic 'App']

    Panic: Assert Failed: "_hEventLog != 0" @ d:/build/ob/bora-256596/bora/sysimage/ufad/common/ufadLogWin32.cpp:109
    Backtrace:
    backtrace[00] rip 10111f1d Vmacore::System::Stacktrace::CaptureFullWork
    backtrace[01] rip 100eb244 Vmacore::System::SystemFactoryImpl::CreateFileWriter
    backtrace[02] rip 100ebc37 Vmacore::System::SystemFactoryImpl::CreateBacktrace
    backtrace[03] rip 10133029 Vmacore::PanicExit
    backtrace[04] rip 101330dd Vmacore::PanicExit
    backtrace[05] rip 10077ab4 Vmacore::RunTimeFailure
    backtrace[06] rip 5f4f79d5 Ufad_LogVararg
    backtrace[07] rip 5f4f7be5 Ufad_RegisterEventLog
    backtrace[08] rip 5f4f76b9 Ufad_Log
    backtrace[09] rip 013b4a0a (no symbol)
    backtrace[10] rip 013b567c (no symbol)
    backtrace[11] rip 72712a47 endthreadex
    backtrace[12] rip 77179ed2 RtlInitializeExceptionChain
    backtrace[13] rip 77179ea5 RtlInitializeExceptionChain

    [2011-07-07 12:32:32.852 09652 panic 'App'] Assert Failed: "_hEventLog != 0" @ d:/build/ob/bora-256596/bora/sysimage/ufad/common/ufadLogWin32.cpp:109

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.  



Environment

VMware vCenter Update Manager 5.0.x
VMware vCenter Update Manager 5.1.x
VMware vCenter Update Manager 4.1.x
VMware vCenter Update Manager 5.5.x
VMware vCenter Update Manager 6.0.x

Cause

This issue occurs when VMware Update Manager is unable to register an event log handle with the Windows Event Log service which indicates the service is not running.

Resolution

To resolve this issue, ensure that the Windows Event Log service is started and is set to Automatic.
To set the Windows Event Log service to Automatic:
  1. In the server where Update Manager is installed, click Start > Administration Tools > Services > Windows Event Log.
  2. Right-click Windows Event Log and click Automatic.
  3. Click OK.