vSphere Web Client 6.0 displays an internal error after upgrading to vSphere 6.0
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vSphere Web Client 6.0 displays an internal error after upgrading to vSphere 6.0

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Article ID: 343862

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Updated On:

Products

VMware VMware vCenter Server

Issue/Introduction

After upgrading to vSphere 6.0, you experience these symptoms:

  • The vSphere Web Client 6.0 displays an internal error.
  • When logging in to the vSphere Web Client 6.0, you see the error:
An internal error has occurred - Unable to load resource module from /phonehome/locales/ph-admin-ui-en_US.swf.
An internal error has occurred - Unable to load resource module from /webCLientUI/locales/WebClientUI-en_US.swf
Reloading the client is recommended, so as to clear any problems left by this error

Environment

  • VMware vCenter Server 6.0.x
  • VMware vCenter Server Appliance 6.0.x
  • VMware vCenter Support Assistant 5.5.x

Cause

This issue happens when installed plug-ins are not supported in the vSphere 6.0 environment. Following are two scenarios:
  • vRealize Operations Manager versions prior to 5.8.5 are not supported in the vSphere 6.0 environment.
  • vCenter Support Assistant 5.5 is not supported in the vSphere 6.0 environment.

    For more information, see the VMware Product Interoperability Matrixes.

    Note: This issue could also occur due to any third party plug-ins installed.

Resolution

  • In vRealize Operations Manager 5.8.5 or versions
Upgrade vRealize Operations Manager to 5.8.5 or later. 
  • In vCenter Support Assistant
Disable the plug-in through the Client Plug-In manager within the vSphere Web Client or upgrade to a compatible version.
 
Note: Consult third party documentation for compatibility of plug-ins with vSphere 6.0.
 
To disable the plug-in through the Client Plug-In manager within the vSphere Web Client:
  1. Log in to the vSphere Web Client as an vCenter Server Administrative user.
  2. When the error appears, click No.
  3. Navigate to Administration > Client Plug-Ins.
  4. Locate the plug-in causing the issue.

    For example, for vCenter support assistant, select VMware vCenter Support Assistant WebClientPluginPackage.
  5. Right-click and click Disable.
  6. Click Yes on the pop-up box for disabling the plug-in.

Additional Information