VMware vSphere Update Manager fails to start with error: Not well-formed (invalid token)
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Article ID: 343817
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Updated On:
Products
VMware vCenter Server
VMware vSphere ESXi
Issue/Introduction
Symptoms:
- VMware vSphere Update Manager service fails to start.
- Attempting to open jetty-vum-ssl.xml may fail.
Note: The file is located at C:/Program Files (x86)/VMware/Infrastructure/Update Manager/jetty-vum-ssl.xml.
- jetty-vum-ssl.xml file may be blank, or may contain random non-ASCII characters.
- In the vum-server-log4cpp.log, you see entries similar to:
[2014-01-16 14:32:55:270 'ManagedJetty' 4632 ERROR] [managedJetty, 232] Failed to parse C:/Program Files (x86)/VMware/Infrastructure/Update Manager/jetty-vum-ssl.xml. Error: not well-formed (invalid token)
Note: The vum-server-log4cpp.log file is located at C:\ProgramData\VMware\VMware Update Manager\Logs.
Environment
VMware vSphere Update Manager 5.0.x
VMware vSphere Update Manager 5.5.x
VMware vSphere Update Manager 5.1.x
VMware vSphere Update Manager 6.0.x
Cause
This issue occurs when the jetty-vum-ssl.xml file is corrupt, as per the log entries located at C:\ProgramData\VMware\VMware Update Manager\Logs.
The .xml file is necessary for vSphere Update Manager to function properly.
Resolution
To resolve this issue, complete one of these actions:
- Restore the corrupt jetty-vum-ssl.xml file from backup.
- Replace the jetty-vum-ssl.xml file by uninstalling and reinstalling vSphere Update Manager.
Note: A copy of jetty-vum-ssl.xml file is attached to this article.
Additional Information
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