VMware vCenter Server 6.5.x
VMware vCenter Server 6.7.x
This table summarizes common errors encountered during vCenter Server installation, upgrade and firstboot related to the vAPI Endpoint Service.
| Symptoms | Resolution |
| After upgrading to vCenter 6.5 Update 2 the vAPI Endpoint service fails to start or crashes continually | vmware-vapi-endpoint fails to start or crashes after upgrading to vCenter Server 6.5 Update 2. (342879) |
| vAPI Endpoint service fails to start when connecting to vCenter Server using vSphere Web Client | "Error [500] SSO error: com.vmware.vim.vmomi.core.exception...." occurs when VMware VAPI Endpoint service fails to start (322851) |
| Failed to configure vAPI Endpoint Service at the firstboot time' error while upgrading VCSA 6.7 with no DNS record fails | |
| Failed to configure vAPI Endpoint Service at the firstboot time" upgrading vCenter Server Appliance 6.7 |
Note: This table is not exhaustive and may not include all possible error scenarios.