Adding or configuring adapter instance fails in vRealize Operations Manager
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Adding or configuring adapter instance fails in vRealize Operations Manager

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Article ID: 343692

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
On adding or configuring an adapter instance in vRealize Operations Manager, you see one of this error:

  • Unable to communicate with server. Number of resources can be 0 only if resource is marked for delete.
  • Unable to establish a valid connection to the target system. Number of resources can be 0 only if resource is marked for delete.


Environment

VMware vRealize Operations Manager 6.2.x
VMware vRealize Operations Manager 6.1.x
VMware vRealize Operations Manager 6.0.x

Cause

The issue occurs when an existing adapter instance on the vRealize Operations Manager node or collector group is in an invalid or unexpected state.

Resolution

To resolve the issue, remove the Adapter instance that is in the invalid or unexpected state.

To identify the Adapter Instances in an invalid or unexpected state:
  1. Log in to vRealize Operations Manager UI as admin user.
  2. Navigate to Administration > Inventory Explorer
  3. Expand Adapter Instances in the Inventory Explorer list
  4. Select each Adapter Instance listed under Adapter Instances
  5. Review the selected Adapter Instance objects in the list on the right.
  6. Look for the Collection State column. Valid collection states are Collecting or Not Collecting. If the collection state for any Adapter Instance is empty or blank, take note of that Adapter Instance as it has an invalid or unexpected state.

To remove the Adapter Instances identified as having an invalid or unexpected state:
  1. Log in to vRealize Operations Manager UI.
  2. Navigate to Administration > Solutions.
  3. Select the Solution from the list that provides the Adapter Type of the identified Adapter Instance
  4. Click the gears icon to configure the Solution
  5. In the Manage Solution dialog select the Adapter Type from the list at the top, then select the identified Adapter Instance from the list on the left.
  6. Click red X to remove the Adapter Instance

Note: All Solutions does not provide the Manage Solution dialog in the UI. If the identified Adapter Instance does not have a UI to allow removal, please contact VMware Support for assistance.