Upgrading vRealize Operations Manager 6.7 to 7.0 or 7.5 fails validation
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Upgrading vRealize Operations Manager 6.7 to 7.0 or 7.5 fails validation

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Article ID: 343685

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Applying the OS or Application upgrade fails quickly.
  • The Software Update tab in the Admin UI displays the status Failed The PAK action "validate" script "source ./pak_python_wrapper.sh validate.py" failed for one or more nodes.
  • The /storage/vcops/log/pakManager/PAK_name/validate_stderr.log on one or more nodes shows error similar to:
DEBUG - Reading from "/storage/log/vcops/log/vcops-watchdog/vcops-watchdogHistory.json" watchdog state file
ERROR - service_restarts_check failed, No JSON object could be decoded
Traceback (most recent call last):
  File "validate.py", line 1974, in main
    result, result_description = getattr(envInfo, check_name)()
  File "validate.py", line 886, in service_restarts_check
    data = json.load(w_history)
  File "/usr/lib/vmware-vcopssuite/python/lib/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib/vmware-vcopssuite/python/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/vmware-vcopssuite/python/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/vmware-vcopssuite/python/lib/python2.7/json/decoder.py", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
ERROR - No JSON object could be decoded
DEBUG - Updating state file with check: service_restarts_check, start_time: False, stop_time: True, result: False, result_desc: No JSON object could be decoded
ERROR - Failed running upgrade: ValueError('No JSON object could be decoded',) is not JSON serializable


Environment

VMware vRealize Operations Manager 6.7.x
VMware vRealize Operations Manager 7.0.x
VMware vRealize Operations Manager 7.5.x

Cause

This issue is caused by an empty or corrupt vcops-watchdogHistory.json file.

Resolution

To resolve this issue, replace, or fix the vcops-watchdogHistory.json file.
  1. Log into the affected node as root via SSH or Console.
Note: An affected node will be any node with the errors in the /storage/vcops/log/pakManager/PAK_name/validate_stderr.log file or with the Failed status in the Software Update tab of the Admin UI as shown in the Symptoms section.
  1. Open /storage/vcops/log/vcops-watchdog/vcops-watchdogHistory.json in a text editor.
  2. Replace the contents of this file with the following:
{
    "actions": [
    ]
}
  1. Save and close the file.
  2. Repeat steps 1-4 for any other affected nodes.
  3. Retry the upgrade installation.