Data drive is inaccessible after Windows GPO update
search cancel

Data drive is inaccessible after Windows GPO update

book

Article ID: 343651

calendar_today

Updated On: 11-09-2024

Products

VMware vSphere ESXi

Issue/Introduction

  • Applying GPO or Microsoft Updates, after guest operating system reboot, unable to access data disk.
  • Disk is visible from Disk management and My Computer, however, it shows as only NTFS.
  • When trying to access the data disk, displays a message Access Denied.
  • When navigating to Drive Properties > Security tab, shows no permissions even though it has admin rights.
  • When trying to update the Security > Permissions, displays the error:

    --------------------------
    Windows Security
    ---------------------------
    Unable to set new owner on Local Disk (D:).
    Access is denied.

Environment

  • VMware vSphere 6.x
  • VMware vSphere 7.x
  • VMware vSphere 8.x

Cause

This issue occurs because Windows Removable Storage Access policy treats the SCSI as Removable Storage If Group policies is set to restrict read and write access on removable devices and the Windows assumes SCSI devices to be detected as hotplug.

For more information, see:

Resolution

Remove the affected Computer from Group Policy objects (GPO) set to restrict read and write access on removable devices.
  1. Navigate to Administrative Templates > System > Removable Storage Access >All Removable Storage classes
  2. Deny all access
  3. If the System is not part of domain, edit the Local Computer policy.

    For more information, see horizon-client-windows-46-install.zip