VMware 製品または VMware Tools のインストール中に発生する MSI エラーのトラブルシューティング
search cancel

VMware 製品または VMware Tools のインストール中に発生する MSI エラーのトラブルシューティング

book

Article ID: 343615

calendar_today

Updated On:

Products

VMware Desktop Hypervisor

Issue/Introduction

この記事では、特定の問題について説明します。上記すべての症状が発生している場合は、この後のセクションを参照してください。これらの症状の一部のみが発生している場合、その問題はこの記事の対象外です。その症状について検索するか、次の記事で同様の問題を確認してください:



Symptoms:

免責事項: これは英文の記事 「Troubleshooting an MSI error during a VMware product or Tools installation (1031302)」の日本語訳です。

記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。

最新情報は英語版の記事で参照してください。

  • VMware Workstation をインストールできない
  • VMware Workstation のインストールが失敗する
  • Windows インストーラ サービスに関するエラーが表示される
  • 次のエラーが表示される:

    The MSI '' failed.


Environment

VMware Workstation 8.x (Windows)
VMware Workstation 7.x (Windows)
VMware Workstation 10.x (Windows)
VMware Player 7.x (Windows)
VMware Player 6.x (Windows)
VMware Player 2.x (Windows)
VMware Player 4.x (Windows)
VMware Workstation 6.x (Windows)
VMware Workstation 11.x (for Windows)
VMware Player Pro 7.x (Windows)
VMware Player 5.x (Windows)
VMware Player 3.x (Windows )
VMware Workstation 9.x (Windows)

Cause

この問題は、Microsoft インストーラによってインストール プロセス中に問題が検出された場合に発生します。これは VMware の問題ではありません。

Resolution

それぞれの手順で、必要に応じて是正措置を取るための指示が提供されます。手順は、問題を隔離し、適切に解決するために最適な順番で並べられています。また、手順は、データの損失を最小限に抑えるために最適な順序で記載されています。それぞれの手順を完了したら、製品のインストールを再試行できます。トラブルシューティングの手順はそれぞれ順番に実行し、手順を飛ばさないでください。

この問題を解決する方法:

  1. ローカル管理者として Windows にログインしていることを確認します。詳細については、以下を参照してください:
  2. Temp ディレクトリの内容をクリアします:
    1. Windows XP の場合、スタート > ファイル名を指定して実行 をクリックします。Windows Vista/7 の場合、スタート / Windows ロゴ ボタン をクリックします。
    2. %TEMP% と入力して Enter を押します。
    3. すべてのファイルを選択して削除します。
  1. 最新バージョンの Windows Installer を再インストールします。詳細およびダウンロード リンクについては、Microsoft のナレッジ ベースの記事 942288 を参照してください。
  2. 現在インストールされているバージョンの Workstation のインストーラを実行し、修復 を選択します。完了したら、PC を再起動して新しいバージョンの Workstation のセットアップを実行します。
  3. Windows 7 以降を使用している場合は、Microsoft のナレッジ ベースの記事 2438651 の Fix it ユーティリティを実行します。
  4. Windows XP を使用している場合は、Microsoft インストーラを再登録します。コマンド プロンプトで、次の 2 つのコマンドを入力します:

    MSIExec /unregister
    MSIExec /regserver


    :コマンド プロンプトの詳細については、コマンドまたはシェル プロンプトを開く (1003892) (Opening a command or shell prompt (1003892)) を参照してください。

  5. Windows システム構成 (msconfig) ユーティリティを使用して、すべての Microsoft 以外のスタートアップ ユーティリティを無効にします。詳細は、Windows システム構成ユーティリティの使用 (1004010) (System Configuration utility (1004010)) を参照してください。有効にした Microsoft サービスのみが実行されるように、Windows を再起動します。
  6. コマンド プロンプトから、次のコマンドを実行します:

sfc /SCANNOW

このコマンドの詳細については、Microsoft のナレッジ ベースの記事 929833 を参照してください。

  1. 管理権限のある新しいユーザー アカウントを作成し、その新しいユーザーとしてログインします。新しいアカウントからソフトウェアをインストールします。詳細については、以下を参照してください:

Microsoft インストーラの詳細については、Microsoft のナレッジ ベースの記事 2438651 を参照してください。

:このリンクは、2011 年 2 月 7 日時点のものです。リンクが切れているのに気づいた場合はご連絡ください。VMware の担当者がリンクをアップデートします。


Additional Information

Troubleshooting an MSI error during a VMware product or Tools installation