Networking & Security pages are blank in vSphere Web Client
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Networking & Security pages are blank in vSphere Web Client

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Article ID: 343370

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Updated On:

Products

VMware NSX

Issue/Introduction

Removing of the NSX Plug-in in the vSphere Web Client resolves the issue.

Symptoms:
  • Pages appear blank when opening the Networking & Security in the vSphere Web Client.
     
  • You see the error:

    Could not establish communication with NSX Manager. Please contact administrator.

    Note:
    For additional symptoms and log entries, see the Additional Information section.


Environment

VMware NSX for vSphere 6.3.x
VMware NSX for vSphere 6.2.x
VMware NSX for vSphere 6.4.x
VMware NSX for vSphere 6.0.x
VMware NSX for vSphere 6.1.x

Cause

This issue occurs because the vSphere Web Client's cached NSX API definition file is newer than the NSX Manager version.

The vSphere Web Client caches the NSX API definition file for the latest version of NSX Manager it connects to. It only upgrades the cached version when it detects a newer one, but does not downgrade it when connecting to an older NSX Manager. The API definition file version must match the NSX Manager version for communication to be successful.

Resolution

To resolve this issue, manually remove the NSX Plug-in for the vSphere Web Client. This triggers the vSphere Web Client to re-cache the version from the next NSX Manager it connects with.

Note: Before proceeding with this procedure, all NSX Managers connecting to a vCenter Server in linked-mode must be running the same version of NSX.

vCenter Server (Windows):

  1. Connect to the vCenter Server using RDP or another remote access solution.
  2. Open the Services administrative control panel snap-in (services.msc).
  3. Right-click the vSphere Web Client service and click Stop.
  4. Create a temporary backup folder.

    For example:

    c:\backup
     
  5. Move the cached NSX plug-in to the temporary backup folder to C:\ProgramData\VMware\vSphere Web Client\vc-packages\vsphere-client-serenity.

    Note:Move any folders starting with com.vmware.vShieldManager- to the temporary backup folder.
     
  6. Re-start the vSphere Web Client.

    To restart the vSphere Web Client:
    • Open the Services administrative control panel snap-in (services.msc).
    • Right-click the VMware vSphere Web Client service.
    • Click Start.
       
  7. Navigate to the Networking & Security > Installation section. vSphere Web Client re-connects to the NSX Manager and downloads the correct Plug-in version.

vCenter Server Appliance (VCSA):

  1. Connect to the VCSA using ssh and enable the shell.
  2. Stop the vSphere Web Client service by running this command:

    service vsphere-client stop
     
  3. Create a temporary backup directory by running this command:

    mkdir /backup
     
  4. Move the cached NSX plug-in to the temporary backup location by running these commands:

    On vSphere 6.0:

    mv /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity/com.vmware.vShieldManager-* /backup

    On vSphere 5.5:

    mv /var/lib/vmware/vsphere-client/vc-packages/vsphere-client-serenity/com.vmware.vShieldManager-* /backup
     
  5. Restart the vSphere Web Client by running this command:

    service vsphere-client start
     
  6. Navigate to the Networking & Security > Installation section. vSphere Web Client re-connects to the NSX Manager and downloads the correct Plug-in version.
Note: If reverting the change is necessary, follow the same procedure as above, however move the folders from the backup directory into the original directory it was taken from.

Additional Information

  • In case of a linked-mode vCenter configuration, the connection to some of the NSX Managers may work while selecting other NSX Managers yields the communication error or a blank page.
  • The Web Client logs contain entries similar to:

    [ERROR] http-bio-9443-exec-302 com.vmware.vshield.ui.common.util.CommonUtil Error occured while getting VSM Replication Role data org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://10.106.17.237/remote/api/ReplicatorConfigurationFacade]; nested exception is org.apache.commons.httpclient.HttpException: Did not receive successful HTTP response: status code = 404, status message = [Not Found]
  • Running the show log command on the NSX Manager console reports entries similar to:

    WARN http-nio-127.0.0.1-7441-exec-1 AbstractClient:142 - Possible remote API mismatch detected. Operation will continue, but errors are likely.

    For more information, see Collecting diagnostic information for VMware NSX for vSphere 6.x (2074678).

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.