Downloading NSX controller tech support log fails
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Downloading NSX controller tech support log fails

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Article ID: 343360

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • Web page timeout error when downloading the Controller Tech Support log bundle from Networking & Security > Installation > Management.
  • Downloading the controller log using GET https://NSX-IP/api/2.0/vdn/controller/controllerId/techsupportlogs fails with HTTP 500 error response.


Environment

VMware NSX for vSphere 6.4.x
VMware NSX for vSphere 6.1.x
VMware NSX for vSphere 6.3.x
VMware NSX for vSphere 6.0.x
VMware NSX for vSphere 6.2.x

Cause

The NSX Manager does not respond to the HTTP request until the file is prepared. If the time to generate the log bundle is greater than the browser's HTTP response timeout, it fails the load.

Resolution

To resolve this issue, increase the browser HTTP Response timeout value or download the log bundle from the controller console using SSH by running the command:
 
$save status-report filename
$copy file filename user@scphost:/path/to/upload


Additional Information