Configuring VMware vCenter Site Recovery Manager (SRM) protection for a virtual machine fails with the error: "Unable to protect virtual machine due to unresolved devices"
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Configuring VMware vCenter Site Recovery Manager (SRM) protection for a virtual machine fails with the error: "Unable to protect virtual machine due to unresolved devices"

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Article ID: 343304

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
When running VMware vCenter Site Recovery Manager (SRM), you experience these symptoms:
  • A virtual machine cannot be protected.
  • Attempting to configure protection fails with the error.
  • You see the error:

    Unable to protect VM VM name due to unresolved devices


Environment

VMware vCenter Site Recovery Manager 5.0.x
VMware vCenter Site Recovery Manager 5.1.x
VMware vCenter Site Recovery Manager 5.5.x

Cause

This issue occurs because inventory mappings have not yet been set up for some resource that is in use for this VM.
 

Resolution

To resolve this issue, review any unknown mapping to a resource.
  1. In the SRM plug-in for the vSphere Client, select the Sites view.
  2. Select the site where the virtual machine is located.
  3. Review the Resource Mappings, Folder Mappings, and Network Mappings tabs.
  4. Ensure each Protected Site Resource has a specified Recovery Site Resource. If a Protected site resource does not exist, double-click the resource and select the appropriate mapping on the Recovery site.

    Note: For more information on configuring SRM Inventory Mappings, see the Select Inventory Mappings section in the Documentation Center. 
     
  5. After the Inventory Mappings have been correctly configured, select the Protection Groups view and select the Protection Group that contains the virtual machine.
  6. Click the Virtual Machines tab, select the virtual machine.
  7. Click Remove Protection, if applicable, and then click Configure Protection to apply the new resource mappings.
  8. Get the storage vendor to check the replication status. 


Workaround:
https://docs.vmware.com/en/Site-Recovery-Manager/8.7/com.vmware.srm.admin.doc/GUID-DEA90D45-A6DE-48F5-8489-0CFA6D1DF3CB.html