Connecting to VMware vCenter Site Recovery Manager fails with the error: Unable to start Site Recovery Manager Service
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Connecting to VMware vCenter Site Recovery Manager fails with the error: Unable to start Site Recovery Manager Service

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Article ID: 343303

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • You are unable to connect to Site Recovery Manager (SRM) through the vSphere Client
  • The SRM service is not running in Windows Services
  • You cannot start the SRM service or the SRM service starts then stops
  • In the vmware-dr-X.log file, you see a backtrace similar to:

    warning 'Persistence'] Rolling back OPEN transaction context: txn_id=0
    warning 'DrServiceInstance'] Initializing service content: std::exception 'class VdbError' "VdbError: Column db_id does not exist in table pd_localsite"
    warning 'DrServiceInstance'] Backtrace:
    backtrace[00] eip 0x007da6e0 ?AbortProcess@System@Vmacore@@YAXXZ
    backtrace[01] eip 0x007dae57 ?CreateBacktrace@SystemFactoryImpl@System@Vmacore@@UAEXAAV?$Ref
    @VBacktrace@System@Vmacore@@@3@@Z
    backtrace[02] eip 0x00415a53 (no symbol)
    backtrace[03] eip 0x02eb944b ?_Activate@EntityWithPermissionsLifetimeMixin
    @Authorize@Dr@@UAEX_N@Z
    backtrace[04] eip 0x0041407f (no symbol)
    backtrace[05] eip 0x0040789e (no symbol)
    backtrace[06] eip 0x0040c453 (no symbol)
    backtrace[07] eip 0x0040e86b (no symbol)
    backtrace[08] eip 0x0040edfa (no symbol)
    backtrace[09] eip 0x034b2de8 ?InitServiceTable@Dr@@YAXPBDKKP6AXABV?$basic_string@DU?$char_traits
    @D@std@@V?$allocator@D@2@@std@@@ZP6AXXZ333@Z
    backtrace[10] eip 0x034b3e2c ?RegisterService@Dr@@YA_N_NPBD1ABV?$basic_string@DU?$char_traits
    @D@std@@V?$allocator@D@2@@std@@@Z
    backtrace[11] eip 0x74d02a47 _endthreadex
    backtrace[12] eip 0x77339d42 RtlInitializeExceptionChain
    backtrace[13] eip 0x77339d15 RtlInitializeExceptionChain
    error 'App'] Application error: VdbError: Column db_id does not exist in table pd_localsite. Shutting down ...

    [serviceWin32,421] vmware-dr service stopped


  • The SRM database is running on a Microsoft SQL database instance


Environment

VMware vCenter Site Recovery Manager 1.0.x
VMware vCenter Site Recovery Manager 4.0.x
VMware vCenter Site Recovery Manager 4.1.x

Cause

This issue occurs if the SQL database user specified in the ODBC connection for SRM does not have the required SQL server role privileges. In most cases, this issue occurs when the SRM database user was assigned the SYSADMIN server role when SRM was installed, but the role or permission was changed after the installation.

Resolution

To resolve this issue, try one of these options:
  • Ensure that you have database administrator privileges.
  • Ensure that you have these permissions:

    • Bulk insert
    • Connect
    • Create table

  • Restore the SYSADMIN SQL server role for the SRM SQL database user. The SYSADMIN role includes all other server roles and is sufficient by itself.
  • Assign the BULK_ADMIN and DB_CREATOR privileges to the user. These are the minimum database privileges required by the SRM SQL database user.

For more information, see the Site Recovery Manager Administration Guide and the Configure Microsoft SQL Server for SRM section in the Site Recovery Manager Installation and Configuration documentation.

Additional Information

This issue can also occur if the schema is not the same as database username.

A Microsoft SQL Server configuration must meet specific requirements to support SRM. SRM requires that the Microsoft SQL Server must have a 32-bit DSN. Microsoft SQL Server has these configuration requirements when used as the SRM database:
  • The database schema has three requirements:

    • It must be owned by the SRM database user (the database user name you supply when configuring the SRM database connection).
    • It must be the default schema for the SRM database user.
    • The database schema name must be the same as the database user name.

  • You must grant the SRM database user these permissions:

    • bulk insert
    • connect
    • create table

  • If you are using Windows authentication, the database user account must be the same user account that you use to run the SRM service.
  • If you are using SQL Authentication, you can leave the default local System user.
  • If the SRM server and database server run on different hosts, you must use mixed mode authentication.
  • If the SQL Server is installed locally, you might need to disable the Shared Memory network setting on the database server.

For more information, see the Microsoft SQL Server Configuration section in the Site Recovery Manager Administration Guide.