"Could not establish communication with NSX Manager" error in SDDC Manager
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Article ID: 343278
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Updated On:
Products
VMware Cloud FoundationVMware NSX
Issue/Introduction
Symptoms:
In an SDDC Manager setup with multiple vCenter Servers and NSX Managers, you experience these symptoms:
When selecting one or more NSX Manager from the vSphere Web Client > Networking and Security, you see an error similar to:
Could not establish communication with NSX Manager. Please contact administrator.
Logging in with SSO administator account ([email protected]) works fine.
Environment
VMware Cloud Foundation 2.0.x VMware NSX for vSphere 6.2.x VMware NSX for vSphere 6.3.x VMware Cloud Foundation 2.1.x
Cause
This issue occurs when the associated NSX Managers are running different versions of VMware NSX for vSphere 6.x or when NSX lookup service is not configured in the NSX environment. It can also occur if the user account does not have appropriate permissions on the NSX Manager.
Resolution
Currently, there is no resolution.
Workaround: To work around this issue:
Ensure that all NSX Managers and other NSX components for all sites have been installed or upgraded to the same NSX version.
Register all NSX Managers in your environmnet to the Lookup Service with their respective External PSC.
Note: Run that /usr/lib/vmware-vmafd/bin/vmafd-cli get-ls-location --server-name localhost command in the vCenter Server applicance to identify the registered PSC details.