Recovery after a failed reprotect
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Recovery after a failed reprotect

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Article ID: 343242

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • Array based replication.
  • Recovery Plan shows as interrupted.
  • Reprotect incomplete VMs showing as Recovery in progress.
  • Failover completed at the array level.


Environment

VMware vCenter Site Recovery Manager 8.x
VMware vCenter Site Recovery Manager 6.5.x
VMware vCenter Site Recovery Manager 6.0.x

Cause

This issue is caused when SRM & SRA are out of sync with each other.

Resolution

Confirm the flow of replication has been restored in the correct direction. If the flow is in the correct direction do the following in this order.
  1. Run Discover Array Pairs.
  2. Try running Recovery/Reprotect again.
  3. If Recovery/Reprotect fails reboot SRM servers and vCenter.
  4. Try running Recovery/Reprotect again.
  5. If Recovery/Reprotect fails destroy the protection group & recovery plan & recreate with the below steps:
 
a) Remove protection from all VMs associated with the protection group.
  1. In the vSphere Web Client, click Site Recovery > Protection Groups.
  2. ​Select an array-based replication or a vSphere Replication protection group and select Related Objects > Virtual Machines.
  3. Right-click a virtual machine and select Remove Protection.
  4. Click Yes to confirm the removal of protection from the virtual machine.
b) Remove the placeholder VMs from inventory.
  1. In the vSphere Web Client, locate the VM at the target site.
  2. Right-click the VM and select Delete From Disk.
  3. Delete the protection group.
  4. In the vSphere Web Client, click Site Recovery > Protection Groups.
  5. Right-click the protection group to delete, and select Delete Protection Group.
d) Delete the recovery plan
  1. In the vSphere Web Client, click Site Recovery > Recovery Plans.
  2. Right-click the recovery plan to delete, and select Delete Recovery Plan.
  3. Recreate protection group.
  4. In the vSphere Web Client, click Site Recovery > Protection Groups.
  5. Click on Create Protection Group and complete the wizard.
f) Recreate recovery plan
  1. In the vSphere Web Client, click Site Recovery > Recovery Plans.
  2. Click on Create Recovery Plan and complete the wizard
 
  1. If you get an error "Can't remove protection from VMs due to error Group <protection group name> is currently used by a recovery plan" then SRM will need to be redeployed as SRM DB and SRM are out of sync on VMs locations.