vCenter Server 5.5 and 6.0 scheduled tasks run one week after scheduled time
search cancel

vCenter Server 5.5 and 6.0 scheduled tasks run one week after scheduled time

book

Article ID: 343188

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Scheduled task does not complete at correct time or day.
  • The Next Run for a Scheduled Task is shifted by a week.
  • This issue can occur if when the scheduled task is configured with this criteria:
    • Creating a scheduled event from the vSphere Client in UTC+X (where X is the time zone adjustment for the client location).
    • Frequency: Monthly
    • Date: Selecting the day of the week instead of the actual date, where the day is 1st, 8th, 15th or 22nd day of the month.
    • Time: Start Time is configured between 00:00 hours and (X-1):59 hours.

      For example
      :
      Using the JST timezone (UTC+9), this issue will occur when a scheduled task is between the hours of 00:00 to 08:59.

Environment

  • VMware vCenter Server 5.5.x
  • VMware vCenter Server 6.0.x
  • VMware vCenter Server 6.5.x
  • VMware vCenter Server 7.0.x
  • VMware vCenter Server 6.7.x

Cause

This issue occurs because vCenter Server stores Scheduled Tasks time as UTC. When creating a task through the vSphere Client, it is created using the local time zone (UTC+X). When this event is stored in the vCenter Server, the time is converted to UTC and cause the Scheduled Task to shift to next week.

Resolution

This is a known issue affecting vCenter Server 5.5 and 6.0.

Currently, there is no workaround or resolution.