The Storage View tab in vCenter Server does not display anything
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The Storage View tab in vCenter Server does not display anything

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Article ID: 343174

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • The Storage Views tab is blank.
  • No errors are found in the SMS, VWS, or STATS log files.
  • The service started normally.
  • In the VI Client log, you see entries similar to:

    [ :ShowYNQ :M: 6] <YYYY-MM-DD> <time>.660 Update Confirmation: Are you sure you want to update? This may take up to a minute, depending on the size of the inventory.
    [ :ShowYNQ :M: 6] <YYYY-MM-DD> <time>.542 Update Confirmation: Are you sure you want to update? This may take up to a minute, depending on the size of the inventory. - selected: Yes
    [SMS: :QuickInf:P:18] <YYYY-MM-DD> <time>.612 WebException occured in Update : System.Net.WebException: The request failed with HTTP status 503: Service Unavailable.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at SmService.Api.smService.Sync(ManagedObjectReference _this)
    at SmService.Data.ServiceProvider.Update()</time></time></time>


Environment

VMware vCenter Server 4.1.x
VMware vCenter Server 5.1.x
VMware vCenter Server 5.5.x
VMware vCenter Server 4.0.x
VMware vCenter Server 5.0.x

Cause

This issue occurs because the SMS proxy is configured with the wrong port in the proxy.xml file.

Resolution

To work around this issue:

  1. Open the proxy.xml file using a text editor.

    The proxy.xml file is located at:

    • Windows 2003 – %AllUsersProfile%\Application Data\VMware\VMware VirtualCenter\
    • Windows 2008 and Windows 2008 R2 – C:\ProgramData\VMware\VMware VirtualCenter\

  2. Change these lines in the proxy.xml file:

    <e id="7">
    <_type>vim.ProxyService.LocalServiceSpec</_type>
    <accessMode>httpsWithRedirect</accessMode>
    <port>8086</port>
    <serverNamespace>/sms</serverNamespace>
    </e>
    <e id="8">
    <_type>vim.ProxyService.LocalServiceSpec</_type>
    <accessMode>httpsWithRedirect</accessMode>
    <port>8086</port>
    <serverNamespace>/ui</serverNamespace>
    </e>


    to:

    <e id="7">
    <_type>vim.ProxyService.LocalServiceSpec</_type>
    <accessMode>httpsWithRedirect</accessMode>
    <port>8080</port>
    <serverNamespace>/sms</serverNamespace>
    </e>
    <e id="8">
    <_type>vim.ProxyService.LocalServiceSpec</_type>
    <accessMode>httpsWithRedirect</accessMode>
    <port>8080</port>
    <serverNamespace>/ui</serverNamespace>
    </e>


  3. Restart the VMware VirtualCenter Server service and start the VMware VirtualCenter Management Webservices service, if it is not already started. For more information, see Stopping, starting, or restarting vCenter services (1003895).

  4. Crosscheck SMS-related port numbers in different configuration files in the setup:

    1. Locate the config.xml file.

      For vCenter Server 5.x:

      C:\Program Files\VMware\Infrastructure\tomcat\webapps\sms\WEB-INF\classes\com\vmware\vim\sms

      For vCenter Server 4.x:

      C:\Program Files\VMware\Infrastructure\tomcat\webapps\sms\WEB-INF\services\smService\com\vmware\vim\sms

    2. Ensure the config.xml file has this line:

      <webServerPort>8080</webServerPort>

    3. Ensure the C:\Program Files\VMware\Infrastructure\tomcat\conf\server.xml file has these lines:

      <Connector protocol="HTTP/1.1" redirectPort="8443"<br>port="8080" URIEncoding="UTF-8"
      connectionTimeout="360000" address="127.0.0.1" />


    4. Ensure the C:\Program Files\VMware\Infrastructure\VirtualCenter Server\extensions\com.vmware.vim.sms\extension.xml file has these lines:

      <health>
      <url>http://localhost:8080/sms/smService-web/health.xml</url>
      </health>


    5. Verify that other vCenter Server services are functioning normally. For more information, see Stopping, starting, or restarting vCenter services (1003895).

Note: If your problem still exists after trying the steps in this article, file a support request with VMware Support and note this Knowledge Base article ID (2003454) in the problem description. For more information, see Filing a Support Request in Customer Connect (2006985).

Additional Information

How to stop, start, or restart vCenter Server services
How to file a Support Request in Customer Connect