Requesting an vRealize Application Services catalog item in VMware vRealize Automation displays a blank page
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Article ID: 342998
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Updated On:
Products
VMware Aria Suite
Issue/Introduction
Symptoms:
Cannot request an vRealize Application Services catalog item from VMware vRealize Automation.
When a user requests a catalog item that was imported from vRealize Application Services, a blank page is displayed
When requesting a catalog item, the blueprint is not deployed.
In the /var/log/vcac/catalina.out log file, you see entries similar to:
20:03:25,609 [tomcat-http--31] [catalog] WARN com.vmware.vcac.platform.rest.RestTemplateIpv6.handleResponseError:524 - GET request for "https://FQDN:8443/darwin/api/csp/callback/forms/deployment.profile.property.details/appd-dp-2/?subtenantId=########-####-####-####-########6a11" resulted in 400 (Bad Request); invoking error handler 20:03:25,610 [tomcat-http--31] [catalog] WARN com.vmware.vcac.platform.rest.client.error.ResponseErrorHandler.handleError:40 - RestErrors can't be mapped to RestException. Error response: [] 20:03:25,611 [tomcat-http--31] [catalog] ERROR com.vmware.vcac.platform.rest.client.error.ResponseErrorHandler.handleError:46 - No RestErrors for HTTP Status Code [400]. Proceeding with the default error handler... 20:03:25,613 [tomcat-http--31] [catalog] ERROR com.vmware.vcac.platform.service.rest.resolver.ApplicationExceptionHandler.handleServiceException:233 - [Error code: 20128 ] - [Error Msg: Failed to retrieve form from provider for ########-####-####-####-########ef61.] [Error code: 20128 ] - [Error Msg: Failed to retrieve form from provider for ########-####-####-####-########ef61.] at com.vmware.vcac.catalog.service.impl.CatalogItemServiceImpl.getRequestForm(CatalogItemServiceImpl.java:226)
Note: This log excerpt is an example. Date, time, and environmental variables may vary depending on your environment.
Environment
VMware vCloud Automation Center for Server 6.0.x VMware vCloud Application Director 6.x
Cause
This issue occurs because the Tomcat has a default header size of 4MB, which may be blocking the calls from vRealize Automation to vRealize Application Services in environments with a large number of groups.
Resolution
To resolve this issue, increase the header size, so that larger SAML headers can be passed from vRealize Automation to the vRealize Application Services.
To increase the size of the SAML header:
Log in to the vRealize Application Services Virtual Appliance as the root user.
Open the /home/darwin/tcserver/darwin/conf/server.xml file using a text editor.
Locate this line in the file:
<Connector SSLEnabled="true" ../>
Add these attributes at the end of the Connector attributes:
Note: Make sure that one of these lines is not already present in the file before you add both of these lines so you are not adding duplicate entries.
URIEncoding="UTF-8" maxHttpHeaderSize="65000"
Restart vRealize Application Services using this command: