vCenter upgrade fails with error: host(s) will be incompatible with upgraded vCenter Server
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vCenter upgrade fails with error: host(s) will be incompatible with upgraded vCenter Server

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Article ID: 342875

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When upgrading the vCenter to the latest version, it will fail with below error:

host(s) will be incompatible with upgraded vCenter Server

Cause

This issue occurs because:
  • vCenter 6.7 does not support ESXi 5.5 and earlier host(s).
  • vCenter 7.0 does not support ESXi 6.0 and earlier host(s).
  • vCenter 8.0 does not support ESXi 6.x and earlier host(s).

Resolution

  1. Upgrade all the ESXi host(s) to a compatible or similar version of the existing version of the vCenter.

    For more information, see Overview of the vSphere Upgrade Process section in the vSphere Upgrade guide.

         Note: Change the product accordingly in the above link.

 

    2.  If the Hosts are already upgraded to the compatible version, then follow the below steps to update in the vPostgres database.

         Identify hosts in the inventory causing incompatibility and upgrade the ESXi host(s) to the compatible versions or higher using the steps below.

    1. Connect to the vCenter Database using appropriate tools
    2. Execute the below SQL query to list the name of hosts which are vCenter Server <version>. For example, for the vCenter Server 7.0 the query is as below. Modify the query version as be version and execute. 
    select dns_name from vpx_host where product_version='7.0.0';
         ​If the host is already in an upgraded version, remove the host from Inventory and add it back to refresh the information

Note: If no feature/solution dependency, you may disconnect the host and remove from inventory without any impact to Virtual Machine. Removing objects from vCenter inventory would cause vCenter internal object ID changes and historical performance data to be lost.

Warning: In case of features like (not limited to) vDS, vSAN, Horizon View etc. take appropriate precautions before removing host(s) from inventory.

Additional Information

For Assistance contact VMware Support Submit a Support Request.