Unable to log in to Admin UI after upgrading to vRealize Operations Manager 5.8.x (formerly known as VMware vCenter Operations Manager 5.8.x)
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Unable to log in to Admin UI after upgrading to vRealize Operations Manager 5.8.x (formerly known as VMware vCenter Operations Manager 5.8.x)

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Article ID: 342858

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Unable to log in to Admin UI after upgrading to vRealize Operations Manager 5.8.x. formerly known as VMware vCenter Operations Manager (Standalone) 5.8.x.
  • Cannot log in to vRealize Operations Manager Admin UI.
  • You see the error:

    Invalid username or password

  • The admin user can successfully log in to the vSphere UI and the Custom UI or to the console of the UI or Analytics virtual machines.


Environment

VMware vCenter Operations Manager (vApp) 5.8.x

Cause

This issue can occur when the group membership for the root and admin users are not updated properly while upgrading vRealize Operations Manager.

Resolution

To resolve this issue, update the group membership for the root and admin users.
To update the group membership for the root and admin users:
  1. Log in to the UI VM as a root user.
  2. Run these commands to update the group membership for the root and admin users:
usermod -G vami,wheel root
usermod -G root,wheel admin
  1. Run this command to restart the process responsible for the admin user interface:
service vcopsadmin restart
  1. Log in to the Analytics VM as a root user.
  2. Run these commands to update the group membership for the root and admin users:

usermod -G vami,wheel root
usermod -G root,wheel admin