Unable to break site pairing from OnPrem SRM on deactivating DRaaS on VMConAWS
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Unable to break site pairing from OnPrem SRM on deactivating DRaaS on VMConAWS

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Article ID: 342596

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Updated On:

Products

VMware Live Recovery VMware Cloud on AWS

Issue/Introduction

Symptoms:

 

After Deactivating DRaaS for SDDC with an active SRM pairing, you are unable to break pairing from your on-prem SRM UI


Environment

VMware vCenter Site Recovery Manager 8.x
VMware vCenter Site Recovery Manager 8.1.x

Cause

 

Known issue is that SRM pairings need to be broken, before one of the SRM instances in the pairing is uninstalled. If SRM instance is uninstalled without its pairing is broken, an orphaned pairing remains on the other SRM instances. An orphaned pairings cannot be removed by the SRM interface. SRM with such pairing needs to be re-installed with a clean DB.
 
The VMC Deactivate DR workflow doesn’t delete for activate SRM pairing. On users’ consent Deactivate DR directly deletes the SRM/VR appliances from the VMC SDDC. In this scenario is possible orphaned pairing or remain on the on-prem SRM instance.

The clean uninstall process is documented in the VMware Site Recovery Installation and Configuration - VMware Site Recovery guide under  "Uninstall Site Recovery Manager on the on-premises site"
 

Resolution

 

To bring the OnPrem site to clean state:

 

  • For VR - you can:


                         1. force stop the leftover replications
                         2. force disconnect the leftover pairing.
                       Alternatively - you can reset VRMS DB and on next startup of VRMS it will remove the stale outgoing replications -                                         open https://vr_address:5480/, click on "Reset embedded db" and do "Save and restart" with SSO Admin password.

 

  • For SRM the only option is to:


                       1. De-install SRM server.
                       2. De-install SRM embedded DB.
                       3. Re-install SRM embedded DB and SRM server.

                       Refer: Unable to modify/repair/uninstall SRM service (56354)